summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/network-ups-tools/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-03-21 03:47:16 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-03-21 03:47:16 (GMT)
commit8fe536ba935dd38e6a1ccfd1066fc9e4d09f1dd3 (patch)
treee34b3a4ee42af84b6d5bbb5aaafa4d5fa877de52 /abs/extra-testing/community/network-ups-tools/PKGBUILD
parent3e0887cb811e0e1bb9fa730c50a22c101117c9fd (diff)
parent72aa4f632af6cae15a7f74973cd8230f30bd8536 (diff)
downloadlinhes_pkgbuild-8fe536ba935dd38e6a1ccfd1066fc9e4d09f1dd3.zip
linhes_pkgbuild-8fe536ba935dd38e6a1ccfd1066fc9e4d09f1dd3.tar.gz
linhes_pkgbuild-8fe536ba935dd38e6a1ccfd1066fc9e4d09f1dd3.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/community/network-ups-tools/PKGBUILD')
-rw-r--r--abs/extra-testing/community/network-ups-tools/PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/abs/extra-testing/community/network-ups-tools/PKGBUILD b/abs/extra-testing/community/network-ups-tools/PKGBUILD
new file mode 100644
index 0000000..515adf8
--- /dev/null
+++ b/abs/extra-testing/community/network-ups-tools/PKGBUILD
@@ -0,0 +1,53 @@
+# $Id: PKGBUILD 12757 2010-03-13 04:22:57Z dgriffiths $
+# Maintainer: Roman Kyrylych <roman@archlinux.org>
+# Contributor: Giuseppe Lucarelli <luk@rebelsoft.org>
+
+pkgname=network-ups-tools
+pkgver=2.4.3
+pkgrel=1
+pkgdesc="NUT is a collection of programs for monitoring and administering UPS hardware"
+arch=('i686' 'x86_64')
+url="http://www.networkupstools.org/"
+license=('GPL2')
+depends=('openssl' 'hal' 'gd')
+makedepends=('libusb')
+backup=(etc/ups/{ups.conf,upsd.conf,upsd.users,upsmon.conf,upssched.conf})
+install=nut.install
+source=(http://www.networkupstools.org/source/2.4/nut-$pkgver.tar.gz run finish)
+options=('!emptydirs' '!libtool')
+
+build() {
+cd $srcdir/nut-$pkgver
+./configure --with-user=nut \
+--prefix=/usr \
+--datadir=/usr/share/ups \
+--sysconfdir=/etc/ups \
+--with-group=nut \
+--with-hal \
+--with-usb \
+--with-cgi \
+--with-cgipath=/usr/share/webapps/nut \
+--with-htmlpath=/usr/share/webapps/nut \
+--with-udev-dir=/etc/udev || return 1
+
+ make || return 1
+ make DESTDIR=$pkgdir install
+ #ugly hack because --with-pkgconfig-dir doesn't work
+ install -D -m644 lib/libupsclient.pc $pkgdir/usr/lib/pkgconfig
+
+ install -D -m644 conf/ups.conf.sample $pkgdir/etc/ups/ups.conf
+ install -D -m640 conf/upsd.conf.sample $pkgdir/etc/ups/upsd.conf
+ install -D -m640 conf/upsd.users.sample $pkgdir/etc/ups/upsd.users
+ install -D -m640 conf/upsmon.conf.sample $pkgdir/etc/ups/upsmon.conf
+ install -D -m644 conf/upssched.conf.sample $pkgdir/etc/ups/upssched.conf
+ install -D -m755 ../run $pkgdir/etc/sv/upsd/run || return 1
+ install -D -m755 ../finish $pkgdir/etc/sv/upsd/finish || return 1
+
+ # Fix udev rules
+ sed -i "s|SYSFS|ATTRS|g" $pkgdir/etc/udev/rules.d/52-nut-usbups.rules
+ install -dm755 ${pkgdir}/lib
+ mv ${pkgdir}/etc/udev ${pkgdir}/lib
+}
+md5sums=('6f893b61b07915e7a139324fa3f79121'
+ '81cfad544c6342125057f9cb978515fb'
+ 'b5b2e266774acfbc80e64ddfbd4057ee')