summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/xbmc-svn/PKGBUILD
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-05-19 14:50:29 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-05-19 14:50:29 (GMT)
commite7cd231a27e5f65ed92b56c85e0e05aeb3645132 (patch)
treedbf476d411690c10963d2f847c2dba0af2dc8114 /abs/extra-testing/community/xbmc-svn/PKGBUILD
parent231f103da1a6df0113b1f6ea3bf005ce1e9db285 (diff)
downloadlinhes_pkgbuild-e7cd231a27e5f65ed92b56c85e0e05aeb3645132.zip
linhes_pkgbuild-e7cd231a27e5f65ed92b56c85e0e05aeb3645132.tar.gz
linhes_pkgbuild-e7cd231a27e5f65ed92b56c85e0e05aeb3645132.tar.bz2
Bumped xbmc-svn to 20449 plus added common remote support
Diffstat (limited to 'abs/extra-testing/community/xbmc-svn/PKGBUILD')
-rw-r--r--abs/extra-testing/community/xbmc-svn/PKGBUILD31
1 files changed, 19 insertions, 12 deletions
diff --git a/abs/extra-testing/community/xbmc-svn/PKGBUILD b/abs/extra-testing/community/xbmc-svn/PKGBUILD
index 2e90b20..e583600 100644
--- a/abs/extra-testing/community/xbmc-svn/PKGBUILD
+++ b/abs/extra-testing/community/xbmc-svn/PKGBUILD
@@ -5,8 +5,8 @@
# for his xbmc-vdpau-vdr PKGBUILD at https://archvdr.svn.sourceforge.net/svnroot/archvdr/trunk/archvdr/xbmc-vdpau-vdr/PKGBUILD
pkgname=xbmc-svn
-pkgver=20231
-pkgrel=3
+pkgver=20449
+pkgrel=1
pkgdesc="XBMC Media Center from SVN (linuxport branch)"
provides=('xbmc')
conflicts=('xbmc' 'xbmc-smoothvideo' 'xbmc-vdpau')
@@ -16,9 +16,9 @@ license=('GPL' 'LGPL')
depends=('alsa-lib' 'curl' 'enca' 'faac' 'freetype2' 'fribidi' 'gawk' 'glew' \
'hal' 'jasper' 'libgl' 'libjpeg>=6b-5' 'libmad' 'libmysqlclient' \
'libxinerama' 'libxrandr' 'lzo2' 'sdl_image' 'sdl_mixer' 'sqlite3' \
- 'tre' 'unzip' 'x-server' 'libcdio' 'libsamplerate')
+ 'tre' 'unzip' 'libcdio' 'libsamplerate' 'python')
makedepends=('subversion' 'autoconf' 'automake' 'boost' 'cmake' 'gcc' 'gperf'
- 'libtool>=2.2.6a-1' 'make' 'nasm' 'patch' 'pkgconfig' 'zip')
+ 'libtool>=2.2.6a-1' 'make' 'nasm' 'patch' 'pkgconfig' 'zip' 'flex' 'bison')
optdepends=('lirc: remote controller support'
'pmount: mount removable devices as normal user'
'smbclient: access windows shares'
@@ -26,14 +26,18 @@ optdepends=('lirc: remote controller support'
install=("${pkgname}.install")
source=('libcurl-not-in-lib64.patch' \
'libfaad2-enable-AC_PROG_CXX.patch' \
- 'xbmc-safe-fullscreen.patch')
+ 'xbmc-safe-fullscreen.patch'
+ 'Lircmap.xml')
noextract=('libcurl-not-in-lib64.patch' \
'libfaad2-enable-AC_PROG_CXX.patch' \
'xbmc-safe-fullscreen.patch')
-md5sums=('96636ee964e37b78ca62235eb10d29c1' \
- '6864778d6adc3ccc79130c294f2fffd9' \
- 'c4d53522773846d8670884cc38f94aa0')
-options=(makeflags)
+
+md5sums=('96636ee964e37b78ca62235eb10d29c1'
+ '6864778d6adc3ccc79130c294f2fffd9'
+ 'c4d53522773846d8670884cc38f94aa0'
+ '3f93186f1ea4aad73011d00754c7265a')
+
+options=(!makeflags)
build() {
@@ -44,10 +48,10 @@ build() {
cd ${srcdir}/
if [ -d $_svnmod/.svn ]; then
msg "SVN tree found, reverting changes and updating to -r$pkgver"
- (cd $_svnmod && svn revert --quiet -R . && svn up --quiet -r $pkgver) || return 1
+ (cd $_svnmod && svn revert -R . && svn up -r $pkgver) || return 1
else
msg "Checking out SVN tree of -r$pkgver"
- svn co $_svntrunk --config-dir ./ --quiet -r $pkgver $_svnmod || return 1
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod || return 1
fi
msg "Done. Starting make..."
@@ -83,7 +87,7 @@ build() {
cd "$srcdir/$_svnmod"
make distclean
./configure --prefix=${_prefix} \
- --disable-debug --disable-pulse --enable-vdpau || return 1
+ --disable-debug || return 1
# Fix false negative detections of realloc that happens some times
if grep -q 'HAVE_REALLOC 0' config.h; then
@@ -121,4 +125,7 @@ build() {
mv ${pkgdir}${_prefix}/share/xbmc/${licensef} \
${pkgdir}${_prefix}/share/licenses/${pkgname} || return 1
done
+
+ # Use custom Lircmap to support StreamZap remote
+ cp $srcdir/Lircmap.xml ${pkgdir}${_prefix}/share/xbmc/system/Lircmap.xml
}