summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-05-20 02:51:25 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-05-20 02:51:25 (GMT)
commitab2f6a2a66c7e2b47d03da81e72109aa96fd9c2c (patch)
tree7b5db6af9db2113343a65fbac37e4821d939ba3c /abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch
parentc1fb5b95e554560a87424a6f3334abf049f999b8 (diff)
parente7cd231a27e5f65ed92b56c85e0e05aeb3645132 (diff)
downloadlinhes_pkgbuild-ab2f6a2a66c7e2b47d03da81e72109aa96fd9c2c.zip
linhes_pkgbuild-ab2f6a2a66c7e2b47d03da81e72109aa96fd9c2c.tar.gz
linhes_pkgbuild-ab2f6a2a66c7e2b47d03da81e72109aa96fd9c2c.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch')
-rw-r--r--abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch b/abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch
new file mode 100644
index 0000000..d112e52
--- /dev/null
+++ b/abs/extra-testing/community/xbmc-svn/xbmc-safe-fullscreen.patch
@@ -0,0 +1,23 @@
+Index: xbmc/Application.cpp
+===================================================================
+--- xbmc/Application.cpp (revision 20059)
++++ xbmc/Application.cpp (working copy)
+@@ -873,6 +873,8 @@
+ #endif
+
+ // set GUI res and force the clear of the screen
++ if (g_guiSettings.GetBool("videoscreen.safefull"))
++ g_guiSettings.m_LookAndFeelResolution = AUTORES;
+ g_graphicsContext.SetVideoResolution(g_guiSettings.m_LookAndFeelResolution, TRUE, true);
+
+ #ifdef _WIN32PC
+@@ -949,6 +951,9 @@
+ time(&seconds);
+ srand((unsigned int)seconds);
+
++ if (g_guiSettings.GetBool("videoscreen.safefull"))
++ g_graphicsContext.ToggleFullScreenRoot();
++
+ return CXBApplicationEx::Create(hWnd);
+ }
+