summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/ddclient/ddclient.rc
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-10-19 19:21:35 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-10-19 19:21:35 (GMT)
commit59bb81e4db2bda0d63e2fb7f895792dba6c20073 (patch)
tree09ed11c77b968807e8c88755fb82236a0d1b7447 /abs/extra-testing/ddclient/ddclient.rc
parent0d75027f7b76a40a8393ea12c9349051d82863d1 (diff)
parent3b0242f860b4efa19fd91a6bd1e3127fd4b8aa9f (diff)
downloadlinhes_pkgbuild-59bb81e4db2bda0d63e2fb7f895792dba6c20073.zip
linhes_pkgbuild-59bb81e4db2bda0d63e2fb7f895792dba6c20073.tar.gz
linhes_pkgbuild-59bb81e4db2bda0d63e2fb7f895792dba6c20073.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/ddclient/ddclient.rc')
-rw-r--r--abs/extra-testing/ddclient/ddclient.rc37
1 files changed, 0 insertions, 37 deletions
diff --git a/abs/extra-testing/ddclient/ddclient.rc b/abs/extra-testing/ddclient/ddclient.rc
deleted file mode 100644
index a9093f7..0000000
--- a/abs/extra-testing/ddclient/ddclient.rc
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/bash
-
-[ -f /etc/conf.d/ddclient ] && . /etc/conf.d/ddclient
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=`pidof -o %PPID /usr/sbin/ddclient`
-case "$1" in
- start)
- stat_busy "Starting ddclient"
- [ -z "$PID" ] && /usr/sbin/ddclient ${EXTRA_ARGS}
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon ddclient
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping ddclient"
- [ -n "$PID" ] && kill -15 $PID >/dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon ddclient
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac