summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/dnsmasq/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-03-18 21:25:13 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-03-18 21:25:13 (GMT)
commitfd3f5c9e4a68d535247925ef3c72b69442f416ad (patch)
treeac0f3af87a327b8448f1f2e1995cb05c68299cd1 /abs/extra-testing/dnsmasq/PKGBUILD
parente18020d18dca7a5261283236359d833a60ef720a (diff)
downloadlinhes_pkgbuild-fd3f5c9e4a68d535247925ef3c72b69442f416ad.zip
linhes_pkgbuild-fd3f5c9e4a68d535247925ef3c72b69442f416ad.tar.gz
linhes_pkgbuild-fd3f5c9e4a68d535247925ef3c72b69442f416ad.tar.bz2
dnsmasq: initial import for extra
does not have a runit script, but that will be added. refs 567
Diffstat (limited to 'abs/extra-testing/dnsmasq/PKGBUILD')
-rw-r--r--abs/extra-testing/dnsmasq/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/abs/extra-testing/dnsmasq/PKGBUILD b/abs/extra-testing/dnsmasq/PKGBUILD
new file mode 100644
index 0000000..a413df4
--- /dev/null
+++ b/abs/extra-testing/dnsmasq/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 66607 2010-02-01 01:42:17Z giovanni $
+# Maintainer: Paul Mattal <paul@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=dnsmasq
+pkgver=2.52
+pkgrel=1
+pkgdesc="Lightweight, easy to configure DNS forwarder and DHCP server"
+url="http://www.thekelleys.org.uk/dnsmasq/doc.html"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc' 'bash')
+makedepends=('libcap>=2.16')
+backup=('etc/dnsmasq.conf')
+install=
+source=("http://www.thekelleys.org.uk/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'rc.dnsmasq')
+md5sums=('1bb32fffdb4f977ead607802b5d701d0' 'e956eee1ec24212a3254d2b168187495')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # Build
+ make || return 1
+
+ # Install
+ install -d $pkgdir/etc/rc.d || return 1
+ make PREFIX=/usr DESTDIR=$pkgdir install || return 1
+
+ install -D -m755 \
+ $srcdir/rc.dnsmasq $pkgdir/etc/rc.d/dnsmasq || return 1
+ install -D -m644 \
+ dnsmasq.conf.example $pkgdir/etc/dnsmasq.conf || return 1
+
+ # Make the Required Directories for DHCP Server Default Directories
+ install -d $pkgdir/var/db || return 1
+ install -d $pkgdir/var/lib/misc || return 1
+}
+
+# vim: ts=2 sw=2 et ft=sh