summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/evtest/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-05-10 23:22:04 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-05-10 23:22:04 (GMT)
commit67d9a0569866a6fd5e6b8df6c4600916e6e4ae5b (patch)
tree43d3d58cfc527ca859ab957b57e25d3b17f7dece /abs/extra-testing/evtest/PKGBUILD
parent1587de87b062dffdafe3b63bbd329c1eb1f91df9 (diff)
downloadlinhes_pkgbuild-67d9a0569866a6fd5e6b8df6c4600916e6e4ae5b.zip
linhes_pkgbuild-67d9a0569866a6fd5e6b8df6c4600916e6e4ae5b.tar.gz
linhes_pkgbuild-67d9a0569866a6fd5e6b8df6c4600916e6e4ae5b.tar.bz2
evtest:initial inclusion
Diffstat (limited to 'abs/extra-testing/evtest/PKGBUILD')
-rw-r--r--abs/extra-testing/evtest/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/extra-testing/evtest/PKGBUILD b/abs/extra-testing/evtest/PKGBUILD
new file mode 100644
index 0000000..0952c5e
--- /dev/null
+++ b/abs/extra-testing/evtest/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Andrej Gelenberg <andrej.gelenberg@udo.edu>
+pkgname=evtest
+pkgver=1.25
+pkgrel=2
+pkgdesc="Simple tool for input event debugging."
+arch=('i686' 'x86_64')
+url="http://cgit.freedesktop.org/~whot/evtest/"
+license=('GPL')
+depends=(libxml2)
+makedepends=(xmlto asciidoc)
+optdepends=(libxslt)
+source=("http://cgit.freedesktop.org/~whot/evtest/snapshot/$pkgname-$pkgver.zip" "evtest.diff")
+
+build()
+{
+ cd $srcdir/$pkgname-$pkgver
+ patch -p1 < ../evtest.diff || return 1
+ autoreconf -iv
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+}
+md5sums=('1edddfcd366bb52490e08cbf1dbaeddf'
+ '1753bd5825ca7e5244a1a09029b8a47d')