summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/gnuplot/PKGBUILD
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-07-29 09:35:03 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-07-29 09:35:03 (GMT)
commitabec4e25d1d51d407c0a9ddefa6304cca013e897 (patch)
tree5523ffb71511ad95e3ab0c487e3959439a2e825e /abs/extra-testing/gnuplot/PKGBUILD
parent4159bd66e3adbf81679c68dfbe6a01486a3f53db (diff)
parentcd301114df042f35f6176d8ea210a26ad3ed31a7 (diff)
downloadlinhes_pkgbuild-abec4e25d1d51d407c0a9ddefa6304cca013e897.zip
linhes_pkgbuild-abec4e25d1d51d407c0a9ddefa6304cca013e897.tar.gz
linhes_pkgbuild-abec4e25d1d51d407c0a9ddefa6304cca013e897.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/gnuplot/PKGBUILD')
-rw-r--r--abs/extra-testing/gnuplot/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra-testing/gnuplot/PKGBUILD b/abs/extra-testing/gnuplot/PKGBUILD
new file mode 100644
index 0000000..24a801a
--- /dev/null
+++ b/abs/extra-testing/gnuplot/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: damir <damir@archlinux.org>
+# Contributor: Niklas Volbers <mithrandir42@web.de>
+
+pkgname=gnuplot
+pkgver=4.0.0
+pkgrel=1
+pkgdesc="Command-line driven interactive data and function plotting utility"
+url="http://www.gnuplot.info"
+depends=('gd>=2.0.29' 'wxgtk')
+makedepends=('texinfo')
+license='custom'
+arch=('i686')
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz)
+md5sums=(66258443d9f93cc4f46b147dac33e63a)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --datadir=/usr/share \
+ --libexecdir=/usr/bin \
+ --with-readline=gnu \
+ --enable-history-file \
+ --with-x
+
+ make X11_DRIVER_DIR='/usr/bin' || return 1
+
+ make DESTDIR=$startdir/pkg \
+ libexecdir=/usr/bin \
+ pkglibexecdir=/usr/bin install
+
+ install -D $startdir/src/$pkgname-$pkgver/Copyright $startdir/pkg/usr/share/licenses/custom/gnuplot/Copyright
+}