summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/gnuplot/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-01 03:14:54 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-01 03:14:54 (GMT)
commit7b35632e80f168d8c5f2220bf610ee7e24b81270 (patch)
tree8facf3fa565911f056a08e38f6a5eed0f756f9c6 /abs/extra-testing/gnuplot/PKGBUILD
parent7e10f51870aa10be3b35d7912a7b54e30f608bb8 (diff)
parent7accc0f042acdfdca9f067b1d4011d6ac01b1a74 (diff)
downloadlinhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.zip
linhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.tar.gz
linhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/extra-testing/gnuplot/PKGBUILD')
-rw-r--r--abs/extra-testing/gnuplot/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra-testing/gnuplot/PKGBUILD b/abs/extra-testing/gnuplot/PKGBUILD
new file mode 100644
index 0000000..ec372f0
--- /dev/null
+++ b/abs/extra-testing/gnuplot/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: damir <damir@archlinux.org>
+# Contributor: Niklas Volbers <mithrandir42@web.de>
+
+pkgname=gnuplot
+pkgver=4.2.5
+pkgrel=1
+pkgdesc="Command-line driven interactive data and function plotting utility"
+url="http://www.gnuplot.info"
+depends=('gd>=2.0.29' 'wxgtk' 'libjpeg>=7')
+makedepends=('texinfo')
+license='custom'
+arch=('i686')
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz)
+md5sums=(85d042f8efd7aae3d9cbfd85b14d06d2)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --datadir=/usr/share \
+ --libexecdir=/usr/bin \
+ --with-readline=gnu \
+ --enable-history-file \
+ --with-x
+
+ make X11_DRIVER_DIR='/usr/bin' || return 1
+
+ make DESTDIR=$startdir/pkg \
+ libexecdir=/usr/bin \
+ pkglibexecdir=/usr/bin install
+
+ install -D $startdir/src/$pkgname-$pkgver/Copyright $startdir/pkg/usr/share/licenses/custom/gnuplot/Copyright
+}