summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/gpac
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
commitc38715641e214272ad7dc6d495edd29940366e7f (patch)
tree9dcd507543e67458d98fa7462f62026041524047 /abs/extra-testing/gpac
parent3d91b06198a56b6579cb0bd77de65f5908571b87 (diff)
downloadlinhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.zip
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.gz
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.bz2
packages that will be needed in the future.
This is the initial merge of packages from MythVantage that are not MythVantage specific.
Diffstat (limited to 'abs/extra-testing/gpac')
-rwxr-xr-xabs/extra-testing/gpac/PKGBUILD50
-rwxr-xr-xabs/extra-testing/gpac/gpac-0.4.2-ffmpeg-errno.patch20
2 files changed, 70 insertions, 0 deletions
diff --git a/abs/extra-testing/gpac/PKGBUILD b/abs/extra-testing/gpac/PKGBUILD
new file mode 100755
index 0000000..a89db81
--- /dev/null
+++ b/abs/extra-testing/gpac/PKGBUILD
@@ -0,0 +1,50 @@
+pkgname=gpac
+pkgver=0.4.2
+pkgrel=3
+arch=("i686")
+pkgdesc="A multimedia framework based on the MPEG-4 Systems standard"
+url="http://gpac.sourceforge.net"
+options=(strip !docs !libtool !emptydirs)
+depends=('freetype2' 'spidermonkey' 'libjpeg' 'libpng' 'libmad' 'xvidcore' 'ffmpeg' 'libogg' 'faad2' 'libxml2' 'sdl' 'libvorbis' 'libtheora')
+source=(http://easynews.dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/${pkgname}-${pkgver}-patches.tar.bz2
+gpac-0.4.2-ffmpeg-errno.patch)
+md5sums=('834910b42ef007410fcc49a5acd4656b' '7c40146553ab621154e52a8c43344083')
+
+build() {
+ cd $pkgname
+ patch -p1 -i $startdir/src/$pkgname-$pkgver-DESTDIR.patch
+ patch -p0 -i $startdir/src/$pkgname-$pkgver-configure-ogg.patch
+ patch -p1 -i $startdir/src/$pkgname-$pkgver-nostrip.patch
+ patch -p1 -i $startdir/src/$pkgname-$pkgver-soname.patch
+ patch -p1 -i $startdir/src/$pkgname-$pkgver-static-defs.patch
+ patch -p1 -i $startdir/src/$pkgname-$pkgver-ffmpeg-snapshots-compat.patch
+ patch -p1 -i $startdir/src/$pkgname-$pkgver-ffmpeg-errno.patch
+ sed -i 's/ldconfig / /' Makefile
+ sed -i 's/-Wall//' Makefile
+ patch -p1 -i $startdir/src/$pkgname-$pkgver-pic.patch
+ chmod +x configure
+ sed -i -e 's/has_wx=yes/has_wx=no/' configure
+ sed -i -e 's/osmozilla//g' applications/Makefile
+ ./configure --prefix=/usr \
+ --use-ogg=system \
+ --use-vorbis=system \
+ --use-theora=system \
+ --use-ffmpeg=system \
+ --use-xvid=system \
+ --use-ft=system \
+ --use-png=system \
+ --use-js=system \
+ --use-mad=system \
+ --use-jpeg=system \
+ --disable-wx
+ make OPTCFLAGS="${CFLAGS}" || return 1
+ make DESTDIR="${startdir}/pkg" install
+ make DESTDIR="${startdir}/pkg" install-lib
+ ln -sf MP4Box ${startdir}/pkg/usr/bin/mp4box
+ ln -sf MP4Client ${startdir}/pkg/usr/bin/mp4client
+ install -d ${startdir}/pkg/usr/man/man1
+ cp doc/man/mp4box.1 ${startdir}/pkg/usr/man/man1
+ cp doc/man/mp4client.1 ${startdir}/pkg/usr/man/man1
+ cp doc/man/gpac.1 ${startdir}/pkg/usr/man/man1
+}
diff --git a/abs/extra-testing/gpac/gpac-0.4.2-ffmpeg-errno.patch b/abs/extra-testing/gpac/gpac-0.4.2-ffmpeg-errno.patch
new file mode 100755
index 0000000..ec59cec
--- /dev/null
+++ b/abs/extra-testing/gpac/gpac-0.4.2-ffmpeg-errno.patch
@@ -0,0 +1,20 @@
+Index: gpac/modules/ffmpeg_in/ffmpeg_demux.c
+===================================================================
+--- gpac.orig/modules/ffmpeg_in/ffmpeg_demux.c
++++ gpac/modules/ffmpeg_in/ffmpeg_demux.c
+@@ -23,6 +23,7 @@
+ */
+
+ #include "ffmpeg_in.h"
++#include <errno.h>
+
+ /*default buffer is 200 ms per channel*/
+ #define FFD_DATA_BUFFER 800
+@@ -285,7 +286,6 @@ static GF_ESD *FFD_GetESDescriptor(FFDem
+ case CODEC_ID_MP3:
+ esd->decoderConfig->objectTypeIndication = 0x69;
+ break;
+- case CODEC_ID_MPEG4AAC:
+ case CODEC_ID_AAC:
+ if (!dec->extradata_size) goto opaque_audio;
+ esd->decoderConfig->objectTypeIndication = 0x40;