summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/graphload
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-07-29 09:35:03 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-07-29 09:35:03 (GMT)
commitabec4e25d1d51d407c0a9ddefa6304cca013e897 (patch)
tree5523ffb71511ad95e3ab0c487e3959439a2e825e /abs/extra-testing/graphload
parent4159bd66e3adbf81679c68dfbe6a01486a3f53db (diff)
parentcd301114df042f35f6176d8ea210a26ad3ed31a7 (diff)
downloadlinhes_pkgbuild-abec4e25d1d51d407c0a9ddefa6304cca013e897.zip
linhes_pkgbuild-abec4e25d1d51d407c0a9ddefa6304cca013e897.tar.gz
linhes_pkgbuild-abec4e25d1d51d407c0a9ddefa6304cca013e897.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/graphload')
-rw-r--r--abs/extra-testing/graphload/PKGBUILD16
-rwxr-xr-xabs/extra-testing/graphload/graphload.sh17
2 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra-testing/graphload/PKGBUILD b/abs/extra-testing/graphload/PKGBUILD
new file mode 100644
index 0000000..4fa0e66
--- /dev/null
+++ b/abs/extra-testing/graphload/PKGBUILD
@@ -0,0 +1,16 @@
+pkgname=graphload
+pkgver=1
+pkgrel=1
+pkgdesc="command to graph the total CPU utilization for N-core systems for a given interval"
+depends=('gnuplot>=4.0.0')
+license='GPLv2'
+arch=('i686')
+
+build() {
+ LH_ROOT=/usr/LH
+ mkdir -p $startdir/pkg/$LH_ROOT/bin/
+
+ cd $startdir
+ # executables
+ install -m0755 -D graphload.sh $startdir/pkg/$LH_ROOT/bin/
+}
diff --git a/abs/extra-testing/graphload/graphload.sh b/abs/extra-testing/graphload/graphload.sh
new file mode 100755
index 0000000..79023ec
--- /dev/null
+++ b/abs/extra-testing/graphload/graphload.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+MYTICKS=100
+MYINTERVAL=4 # we sample once every $MYINTERVAL seconds
+MYINVERSEINTERVAL=0.25
+
+top -d $MYINVERSEINTERVAL -n $MYTICKS -b -i | grep Cpu | perl -e "while(<>) { split(','); \$load = 100 - substr @_[3], 0, -3; print \$load,\"\n\";}" > profile
+perl -e '$second=0; while(<>) { chop(); $load = $_; print "$second $load "; split " ", $load; print @_[0] + @_[1], "\n"; $second+=0.25;}' < profile > points
+echo "set grid
+set xrange [0: $(($MYTICKS/$MYINTERVAL))]
+set yrange [0: 101]
+set xtics 0,$MYINVERSEINTERVAL,$(($MYTICKS/$MYINTERVAL))
+set xlabel \"time\"
+set ylabel \"CPU usage\"
+plot \"points\" using 1:2 with lines title 'total load'
+replot" > gplot.cmds
+gnuplot -persist gplot.cmds