summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/hspell/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-14 18:14:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-14 18:14:45 (GMT)
commitd1619a5abc60f3d9e7d3dad588ff1b92bb23e624 (patch)
tree48d339f8b0f3be940ac1b372c939f22377f983fd /abs/extra-testing/hspell/PKGBUILD
parentc6d1a2299fae2c80be87634f38f6c61a7b8086e6 (diff)
downloadlinhes_pkgbuild-d1619a5abc60f3d9e7d3dad588ff1b92bb23e624.zip
linhes_pkgbuild-d1619a5abc60f3d9e7d3dad588ff1b92bb23e624.tar.gz
linhes_pkgbuild-d1619a5abc60f3d9e7d3dad588ff1b92bb23e624.tar.bz2
Missing makedepends for gnome-python-extras
enchant gdl gnome-doc-utils gtkspell hspell libgksu libgtkhtml libgtop
Diffstat (limited to 'abs/extra-testing/hspell/PKGBUILD')
-rw-r--r--abs/extra-testing/hspell/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra-testing/hspell/PKGBUILD b/abs/extra-testing/hspell/PKGBUILD
new file mode 100644
index 0000000..7700435
--- /dev/null
+++ b/abs/extra-testing/hspell/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 28768 2009-03-02 04:21:08Z eric $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=hspell
+pkgver=1.0
+pkgrel=2
+pkgdesc="Hebrew spell-checker"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://www.ivrix.org.il/projects/spell-checker/"
+depends=('glibc>=2.7' 'zlib' 'perl')
+options=('!libtool' '!makeflags')
+source=(ftp://ftp.archlinux.org/other/hspell/${pkgname}-${pkgver}.tar.gz)
+md5sums=('3e12fa383c2cfd430918d115f33f9841')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ [ "${CARCH}" = "x86_64" ] && export CFLAGS="${CFLAGS} -fPIC"
+ sed -i -e 's|/usr/bin/awk|/bin/awk|' wzip
+ ./configure --prefix=/usr --enable-linginfo
+ make || return 1
+ make DESTDIR=${startdir}/pkg/ install || return 1
+}