summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/irqbalance/irqbalance.rc.d
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-06-01 02:10:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-06-01 02:10:09 (GMT)
commitd7a06c882ef45d014319f98daf8e0dbe5599321d (patch)
tree08283d317915d613a4ea86513e8b8f626ceb243e /abs/extra-testing/irqbalance/irqbalance.rc.d
parent6aec480f40e73de0b179d0a91aa484266190f52b (diff)
parente9dc867012dd4553eeca9a67837688e762fcded6 (diff)
downloadlinhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.zip
linhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.tar.gz
linhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD into linhes-config-python
* 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD: lirc: pkg bump to just make it different then the submitted version in the ticket. lirc: change modmce patch to version 1.5 glass-wide: adding theme irqbalance: adding pkg fakeroot: add package linhes-scripts: adding idle.sh Bumped xbmc-svn to 20449 plus added common remote support fresh build bumped mythtv-svn to 20586 First cut at XBMC (svn with vdpau) updated libjpeg and added libsamplerate for XBMC build mythtv-svn bumped for new qt4 qt updated to 4.5.1 which: pkg bump used for testing, no functional changes. Bumped version to recompile. Bumped version for birthday present to community. Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/extra-testing/irqbalance/irqbalance.rc.d')
-rw-r--r--abs/extra-testing/irqbalance/irqbalance.rc.d46
1 files changed, 46 insertions, 0 deletions
diff --git a/abs/extra-testing/irqbalance/irqbalance.rc.d b/abs/extra-testing/irqbalance/irqbalance.rc.d
new file mode 100644
index 0000000..c8d197f
--- /dev/null
+++ b/abs/extra-testing/irqbalance/irqbalance.rc.d
@@ -0,0 +1,46 @@
+#!/bin/bash
+
+# source application-specific settings
+ONESHOT=0
+[ -f /etc/conf.d/irqbalance ] && . /etc/conf.d/irqbalance
+
+if [ "$ONESHOT" -ne 0 ]; then
+ ONESHOT_CMD="oneshot"
+fi
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/irqbalance`
+case "$1" in
+ start)
+ stat_busy "Starting IRQ balancing"
+ [ -z "$PID" ] && /usr/sbin/irqbalance $ONESHOT_CMD
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ if [ "$ONESHOT" -eq 0 ]; then
+ add_daemon irqbalance
+ fi
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping IRQ balancing"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon irqbalance
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0