summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/libcups/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
commit116edc0c0cc1b926acce635a76d102408b118a92 (patch)
tree237e661dc7f5b1bb4b18350ab3a48e5a15283851 /abs/extra-testing/libcups/PKGBUILD
parent29e945b91760568116a21e0076fae046b33a2663 (diff)
parent7f42f55d022dc8ca818a76dccfc66fce7c8dea4f (diff)
downloadlinhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.zip
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.gz
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/extra-testing/libcups/PKGBUILD')
-rw-r--r--abs/extra-testing/libcups/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra-testing/libcups/PKGBUILD b/abs/extra-testing/libcups/PKGBUILD
new file mode 100644
index 0000000..fbdac67
--- /dev/null
+++ b/abs/extra-testing/libcups/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 20496 2008-12-05 11:29:11Z allan $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=libcups
+pkgver=1.3.9
+pkgrel=2
+pkgdesc="The CUPS Printing System"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.cups.org/"
+depends=('gnutls>=2.4.1' 'libtiff' 'libpng' 'heimdal>=1.2')
+source=(ftp://ftp.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.bz2)
+md5sums=('cf63f451c356e6cabb08972d4d11c365')
+
+build() {
+ cd ${srcdir}/cups-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --with-logdir=/var/log/cups -with-docdir=/usr/share/cups/doc \
+ --with-cups-user=daemon --with-cups-group=lp --enable-ssl=yes \
+ --disable-ldap --disable-dbus --libdir=/usr/lib
+
+ for dir in cups filter; do
+ pushd ${dir}
+ make
+ make BUILDROOT=${pkgdir} install
+ popd
+ done
+
+ mkdir -p ${startdir}/pkg/usr/bin
+ install -m755 cups-config ${startdir}/pkg/usr/bin/cups-config
+ #Remove filters
+ rm -rf ${startdir}/pkg/usr/lib/cups
+}