summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/libcups
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
commit0ce6326882d1ef6b45955ce0af948aa3da22bc07 (patch)
tree6ef646f87190a95deea7641df53c6ee5396c900c /abs/extra-testing/libcups
parent907606040ebd98338b939452ee37698b62718820 (diff)
downloadlinhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.zip
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.gz
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.bz2
Added support for Miro.
Diffstat (limited to 'abs/extra-testing/libcups')
-rw-r--r--abs/extra-testing/libcups/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra-testing/libcups/PKGBUILD b/abs/extra-testing/libcups/PKGBUILD
new file mode 100644
index 0000000..fbdac67
--- /dev/null
+++ b/abs/extra-testing/libcups/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 20496 2008-12-05 11:29:11Z allan $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=libcups
+pkgver=1.3.9
+pkgrel=2
+pkgdesc="The CUPS Printing System"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.cups.org/"
+depends=('gnutls>=2.4.1' 'libtiff' 'libpng' 'heimdal>=1.2')
+source=(ftp://ftp.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.bz2)
+md5sums=('cf63f451c356e6cabb08972d4d11c365')
+
+build() {
+ cd ${srcdir}/cups-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --with-logdir=/var/log/cups -with-docdir=/usr/share/cups/doc \
+ --with-cups-user=daemon --with-cups-group=lp --enable-ssl=yes \
+ --disable-ldap --disable-dbus --libdir=/usr/lib
+
+ for dir in cups filter; do
+ pushd ${dir}
+ make
+ make BUILDROOT=${pkgdir} install
+ popd
+ done
+
+ mkdir -p ${startdir}/pkg/usr/bin
+ install -m755 cups-config ${startdir}/pkg/usr/bin/cups-config
+ #Remove filters
+ rm -rf ${startdir}/pkg/usr/lib/cups
+}