summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/libgdiplus/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-14 17:45:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-14 17:45:02 (GMT)
commit91e7e1105b837173adacd6ca1489cd2814c1ccf7 (patch)
treea9e32d1aef13b10930ccfc697b59f689e8007441 /abs/extra-testing/libgdiplus/PKGBUILD
parentad9a6e9be1f0af2a5c15d4f05e1aa4c9d561e9f0 (diff)
downloadlinhes_pkgbuild-91e7e1105b837173adacd6ca1489cd2814c1ccf7.zip
linhes_pkgbuild-91e7e1105b837173adacd6ca1489cd2814c1ccf7.tar.gz
linhes_pkgbuild-91e7e1105b837173adacd6ca1489cd2814c1ccf7.tar.bz2
Missing makedepends for avahi.
gtk-sharp2 libgdiplus mono
Diffstat (limited to 'abs/extra-testing/libgdiplus/PKGBUILD')
-rw-r--r--abs/extra-testing/libgdiplus/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/extra-testing/libgdiplus/PKGBUILD b/abs/extra-testing/libgdiplus/PKGBUILD
new file mode 100644
index 0000000..3b91775
--- /dev/null
+++ b/abs/extra-testing/libgdiplus/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 15386 2008-10-13 16:29:55Z daniel $
+# Maintainer: daniel@archlinux.org
+
+pkgname=libgdiplus
+pkgver=2.2
+pkgrel=1
+pkgdesc="An Open Source Implementation of the GDI+ API"
+arch=(i686 x86_64)
+license=('MPL' 'LGPL')
+url="http://www.mono-project.com"
+depends=('libtiff' 'cairo>=1.6.4' 'giflib' 'glib2>=2.18.0' 'libexif')
+makedepends=('automake' 'pkgconfig')
+options=('!libtool')
+source=(http://go-mono.com/sources/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('4af9c8171e75f1408c3628a8f7937d9f')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --with-cairo=system
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+}