summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/libpng/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
commit116edc0c0cc1b926acce635a76d102408b118a92 (patch)
tree237e661dc7f5b1bb4b18350ab3a48e5a15283851 /abs/extra-testing/libpng/PKGBUILD
parent29e945b91760568116a21e0076fae046b33a2663 (diff)
parent7f42f55d022dc8ca818a76dccfc66fce7c8dea4f (diff)
downloadlinhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.zip
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.gz
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/extra-testing/libpng/PKGBUILD')
-rw-r--r--abs/extra-testing/libpng/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/abs/extra-testing/libpng/PKGBUILD b/abs/extra-testing/libpng/PKGBUILD
new file mode 100644
index 0000000..12515ed
--- /dev/null
+++ b/abs/extra-testing/libpng/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 22148 2008-12-22 12:33:23Z pierre $
+# Maintainer: dorphell <dorphell@archlinux.org>
+# Maintainer: Travis Willard <travis@archlinux.org>
+# Maintainer: Douglas Soares de Andrade <douglas@archlinux.org>
+
+pkgname=libpng
+pkgver=1.2.34
+pkgrel=1
+pkgdesc="A collection of routines used to create PNG format graphics files"
+arch=('i686' 'x86_64')
+url="http://www.libpng.org/pub/png/libpng.html"
+license=('custom')
+depends=('zlib')
+options=('!libtool')
+source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+ "http://hp.vector.co.jp/authors/VA013651/lib/libpng-${pkgver}-apng.patch.gz")
+options=('!libtool')
+md5sums=('37362876feb21344fd3af1228527db0f'
+ 'a7ee9fd9af34692b75eedd5b03b69ca9')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+
+ # Add animated PNG (apng) support
+ # see http://hp.vector.co.jp/authors/VA013651/freeSoftware/apng.html
+ patch -p1 -i $srcdir/libpng-${pkgver}-apng.patch || return 1
+
+ libtoolize --force --copy || return 1
+ aclocal || return 1
+ autoconf || return 1
+ automake --add-missing || return 1
+
+ ./configure --prefix=/usr || return 1
+ make ECHO=echo || return 1
+ make ECHO=echo DESTDIR=${startdir}/pkg install || return 1
+
+ cd contrib/pngminus
+ make ECHO=echo PNGLIB="-L${startdir}/pkg/usr/lib -lpng" -f makefile.std png2pnm pnm2png
+ install -m755 png2pnm pnm2png ${startdir}/pkg/usr/bin/
+ install -m755 -d ${startdir}/pkg/usr/share/licenses/${pkgname}
+ install -m644 ../../LICENSE ${startdir}/pkg/usr/share/licenses/${pkgname}/ || return 1
+}