summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/libsamplerate
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-06-01 02:10:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-06-01 02:10:09 (GMT)
commitd7a06c882ef45d014319f98daf8e0dbe5599321d (patch)
tree08283d317915d613a4ea86513e8b8f626ceb243e /abs/extra-testing/libsamplerate
parent6aec480f40e73de0b179d0a91aa484266190f52b (diff)
parente9dc867012dd4553eeca9a67837688e762fcded6 (diff)
downloadlinhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.zip
linhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.tar.gz
linhes_pkgbuild-d7a06c882ef45d014319f98daf8e0dbe5599321d.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD into linhes-config-python
* 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD: lirc: pkg bump to just make it different then the submitted version in the ticket. lirc: change modmce patch to version 1.5 glass-wide: adding theme irqbalance: adding pkg fakeroot: add package linhes-scripts: adding idle.sh Bumped xbmc-svn to 20449 plus added common remote support fresh build bumped mythtv-svn to 20586 First cut at XBMC (svn with vdpau) updated libjpeg and added libsamplerate for XBMC build mythtv-svn bumped for new qt4 qt updated to 4.5.1 which: pkg bump used for testing, no functional changes. Bumped version to recompile. Bumped version for birthday present to community. Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/extra-testing/libsamplerate')
-rw-r--r--abs/extra-testing/libsamplerate/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra-testing/libsamplerate/PKGBUILD b/abs/extra-testing/libsamplerate/PKGBUILD
new file mode 100644
index 0000000..1537675
--- /dev/null
+++ b/abs/extra-testing/libsamplerate/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id$
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Jason Chu <jchu@xentac.net>
+
+pkgname=libsamplerate
+pkgver=0.1.7
+pkgrel=1
+pkgdesc="Secret Rabbit Code - aka Sample Rate Converter for audio"
+arch=('i686' 'x86_64')
+url="http://www.mega-nerd.com/SRC/index.html"
+license=('GPL')
+depends=('libsndfile' 'flac>=1.1.4')
+options=('!libtool')
+source=(http://www.mega-nerd.com/SRC/libsamplerate-${pkgver}.tar.gz)
+md5sums=('ad093e60ec44f0a60de8e29983ddbc0f')
+sha1sums=('98a52392eb97f9ba724ca024b3af29a8a0cc0206')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+}