summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/libxcb/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-03 07:56:23 (GMT)
commit0ce6326882d1ef6b45955ce0af948aa3da22bc07 (patch)
tree6ef646f87190a95deea7641df53c6ee5396c900c /abs/extra-testing/libxcb/PKGBUILD
parent907606040ebd98338b939452ee37698b62718820 (diff)
downloadlinhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.zip
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.gz
linhes_pkgbuild-0ce6326882d1ef6b45955ce0af948aa3da22bc07.tar.bz2
Added support for Miro.
Diffstat (limited to 'abs/extra-testing/libxcb/PKGBUILD')
-rw-r--r--abs/extra-testing/libxcb/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra-testing/libxcb/PKGBUILD b/abs/extra-testing/libxcb/PKGBUILD
new file mode 100644
index 0000000..c61df23
--- /dev/null
+++ b/abs/extra-testing/libxcb/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 8004 2008-08-05 18:11:40Z jgc $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+pkgname=libxcb
+pkgver=1.1.90.1
+pkgrel=1
+pkgdesc="X11 client-side library"
+arch=(i686 x86_64)
+url="http://xcb.freedesktop.org/"
+depends=('xcb-proto>=1.2' 'libxdmcp' 'libxau')
+makedepends=('pkgconfig' 'libxslt' 'python')
+options=('!libtool')
+license=('custom')
+source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2
+ libxcb-1.1-no-pthread-stubs.patch
+ libxcb-1.1-sloppy-lock.patch)
+md5sums=('c4b67c5576ed58e2fd4a2855c0b21aa6'
+ 'a53f09ab3ec5cbfc1b0848bd137c535a'
+ '4b3fbedc471d7ab336a18f1d0f853ddd')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Np1 -i ${srcdir}/libxcb-1.1-no-pthread-stubs.patch || return 1
+ patch -Np1 -i ${srcdir}/libxcb-1.1-sloppy-lock.patch || return 1
+ libtoolize --force --copy || return 1
+ aclocal || return 1
+ autoconf || return 1
+ automake --add-missing || return 1
+ ./configure --prefix=/usr --enable-xinput || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
+}