summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/lm_sensors/healthd.rc
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-03-21 03:47:16 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-03-21 03:47:16 (GMT)
commit8fe536ba935dd38e6a1ccfd1066fc9e4d09f1dd3 (patch)
treee34b3a4ee42af84b6d5bbb5aaafa4d5fa877de52 /abs/extra-testing/lm_sensors/healthd.rc
parent3e0887cb811e0e1bb9fa730c50a22c101117c9fd (diff)
parent72aa4f632af6cae15a7f74973cd8230f30bd8536 (diff)
downloadlinhes_pkgbuild-8fe536ba935dd38e6a1ccfd1066fc9e4d09f1dd3.zip
linhes_pkgbuild-8fe536ba935dd38e6a1ccfd1066fc9e4d09f1dd3.tar.gz
linhes_pkgbuild-8fe536ba935dd38e6a1ccfd1066fc9e4d09f1dd3.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/lm_sensors/healthd.rc')
-rw-r--r--abs/extra-testing/lm_sensors/healthd.rc52
1 files changed, 52 insertions, 0 deletions
diff --git a/abs/extra-testing/lm_sensors/healthd.rc b/abs/extra-testing/lm_sensors/healthd.rc
new file mode 100644
index 0000000..7bb7951
--- /dev/null
+++ b/abs/extra-testing/lm_sensors/healthd.rc
@@ -0,0 +1,52 @@
+#!/bin/bash
+
+#
+# /etc/rc.d/healthd
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+. /etc/conf.d/healthd
+
+maybe_alarm_reset() {
+ case "${ALARM_RESET}" in
+ yes) /usr/bin/sensors > /dev/null
+ ;;
+ no) true
+ ;;
+ *) false
+ esac
+ return $?
+}
+
+PID=$(pidof -x -o %PPID /usr/sbin/healthd)
+case "${1}" in
+ start)
+ stat_busy "Starting Health Daemon"
+ [ -z "${PID}" ] && maybe_alarm_reset && /usr/sbin/healthd &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ echo "${PID}" > /var/run/healthd.pid
+ add_daemon healthd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping Health Daemon"
+ [ ! -z "${PID}" ] && kill ${PID} &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon healthd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 2
+ $0 start
+ ;;
+ *) echo "usage: $0 {start|stop|restart}"
+esac
+exit 0