summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/monitorix/monitorix.install
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-03-22 19:37:16 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-03-22 19:37:16 (GMT)
commit21383e4ca51bc151601a51e6d75885959deb89e1 (patch)
treef9c1e3739098b700c0e0421c069ae926cc1b8cc2 /abs/extra-testing/monitorix/monitorix.install
parentdbff62a9a2550bd0bed77860fa4164d74c90dfb3 (diff)
parente51cf415764a2c267f373965c48eec082ad59d81 (diff)
downloadlinhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.zip
linhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.tar.gz
linhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/monitorix/monitorix.install')
-rw-r--r--abs/extra-testing/monitorix/monitorix.install30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/extra-testing/monitorix/monitorix.install b/abs/extra-testing/monitorix/monitorix.install
new file mode 100644
index 0000000..6c1d1bd
--- /dev/null
+++ b/abs/extra-testing/monitorix/monitorix.install
@@ -0,0 +1,30 @@
+remove_notes() {
+ echo '----------------------------------------------------------------------'
+ echo 'To remove all traces of monitorix from your system, you must manually'
+ echo 'remove the following dir trees (doing so will delete your databases):'
+ echo
+ echo '/var/lib/monitorix'
+ echo '/srv/http/monitorix'
+ echo '----------------------------------------------------------------------'
+}
+
+# $1: The new package version
+# $2: The old package version
+post_upgrade() {
+ echo ''
+ echo ''
+ echo 'now edit /etc/monitorix.conf'
+ echo ' our $HOSTNAME - your hostname.'
+ echo ' our $ENABLE_LMTEMP - switch this on if you wanna log your temps.'
+ echo ' our @HDDTEMP_LIST - If you system has more than one hdd, add it to the array.'
+ echo ' stats can be seen at http://$THIS_SYSTEMS_IP/monitorix/'
+
+ echo ''
+ echo ''
+}
+
+post_install(){
+ . /etc/systemconfig
+ sed -i "s/^our \$HOSTNAME.*$/our \$HOSTNAME = \"${hostname}\"\; /" /etc/monitorix.conf|
+ post_upgrade
+}