summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-10-19 19:21:35 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-10-19 19:21:35 (GMT)
commit59bb81e4db2bda0d63e2fb7f895792dba6c20073 (patch)
tree09ed11c77b968807e8c88755fb82236a0d1b7447 /abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch
parent0d75027f7b76a40a8393ea12c9349051d82863d1 (diff)
parent3b0242f860b4efa19fd91a6bd1e3127fd4b8aa9f (diff)
downloadlinhes_pkgbuild-59bb81e4db2bda0d63e2fb7f895792dba6c20073.zip
linhes_pkgbuild-59bb81e4db2bda0d63e2fb7f895792dba6c20073.tar.gz
linhes_pkgbuild-59bb81e4db2bda0d63e2fb7f895792dba6c20073.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch')
-rw-r--r--abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch b/abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch
new file mode 100644
index 0000000..fd1495d
--- /dev/null
+++ b/abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch
@@ -0,0 +1,22 @@
+--- glide64/Combine.old.cpp 2009-06-19 17:59:20.191723065 -0400
++++ glide64/Combine.cpp 2009-06-19 18:43:46.955453868 -0400
+@@ -11873,7 +11873,7 @@
+ LOG ("InitCombine() ");
+ memset(&cmb, 0, sizeof(cmb));
+ const char *extensions = grGetString (GR_EXTENSION);
+- if (char * extstr = strstr(extensions, "COMBINE")) {
++ if (const char * extstr = strstr(extensions, "COMBINE")) {
+ if (!strncmp(extstr, "COMBINE", 7)) {
+ LOG ("extensions ");
+ cmb.grColorCombineExt = (GRCOLORCOMBINEEXT) grGetProcAddress("grColorCombineExt");
+--- glide64/Main.old.cpp 2009-06-19 18:47:04.238930057 -0400
++++ glide64/Main.cpp 2009-06-19 18:47:18.018772876 -0400
+@@ -784,7 +784,7 @@
+ printf("bebefore2\n");
+ if (settings.fb_hires)
+ {
+- if (char * extstr = strstr(extensions, "TEXTUREBUFFER"))
++ if (const char * extstr = strstr(extensions, "TEXTUREBUFFER"))
+ {
+ if (!strncmp(extstr, "TEXTUREBUFFER", 13))
+ {