summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-10-19 12:42:21 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-10-19 12:42:21 (GMT)
commite83014834bac090d027de06e722ce2042cf7f951 (patch)
treeb421a2e33b05c7aad97f9df9baf0a76d76bef765 /abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch
parent601cb5987fe81d489ba4c1bafd96be123f3e7053 (diff)
parent5f0964a527a32478649ab13006c56dcfe9a67b2c (diff)
downloadlinhes_pkgbuild-e83014834bac090d027de06e722ce2042cf7f951.zip
linhes_pkgbuild-e83014834bac090d027de06e722ce2042cf7f951.tar.gz
linhes_pkgbuild-e83014834bac090d027de06e722ce2042cf7f951.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch')
-rw-r--r--abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch b/abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch
new file mode 100644
index 0000000..fd1495d
--- /dev/null
+++ b/abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch
@@ -0,0 +1,22 @@
+--- glide64/Combine.old.cpp 2009-06-19 17:59:20.191723065 -0400
++++ glide64/Combine.cpp 2009-06-19 18:43:46.955453868 -0400
+@@ -11873,7 +11873,7 @@
+ LOG ("InitCombine() ");
+ memset(&cmb, 0, sizeof(cmb));
+ const char *extensions = grGetString (GR_EXTENSION);
+- if (char * extstr = strstr(extensions, "COMBINE")) {
++ if (const char * extstr = strstr(extensions, "COMBINE")) {
+ if (!strncmp(extstr, "COMBINE", 7)) {
+ LOG ("extensions ");
+ cmb.grColorCombineExt = (GRCOLORCOMBINEEXT) grGetProcAddress("grColorCombineExt");
+--- glide64/Main.old.cpp 2009-06-19 18:47:04.238930057 -0400
++++ glide64/Main.cpp 2009-06-19 18:47:18.018772876 -0400
+@@ -784,7 +784,7 @@
+ printf("bebefore2\n");
+ if (settings.fb_hires)
+ {
+- if (char * extstr = strstr(extensions, "TEXTUREBUFFER"))
++ if (const char * extstr = strstr(extensions, "TEXTUREBUFFER"))
+ {
+ if (!strncmp(extstr, "TEXTUREBUFFER", 13))
+ {