summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/myt2xvid3/myt2xvid3.install
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-09 01:00:57 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-09 01:00:57 (GMT)
commita975be5c625c282814c3095ee4d4f23442fb5618 (patch)
tree6659fd05ba702ab89790e9566a2b1f6fa5712696 /abs/extra-testing/myt2xvid3/myt2xvid3.install
parent2496b37b4945453be84122f6823c0c2b7ff79db6 (diff)
parent04641b54e2aaab6f0cff7145af0be518bfee49cd (diff)
downloadlinhes_pkgbuild-a975be5c625c282814c3095ee4d4f23442fb5618.zip
linhes_pkgbuild-a975be5c625c282814c3095ee4d4f23442fb5618.tar.gz
linhes_pkgbuild-a975be5c625c282814c3095ee4d4f23442fb5618.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/myt2xvid3/myt2xvid3.install')
-rwxr-xr-xabs/extra-testing/myt2xvid3/myt2xvid3.install13
1 files changed, 8 insertions, 5 deletions
diff --git a/abs/extra-testing/myt2xvid3/myt2xvid3.install b/abs/extra-testing/myt2xvid3/myt2xvid3.install
index f363fa2..8afb390 100755
--- a/abs/extra-testing/myt2xvid3/myt2xvid3.install
+++ b/abs/extra-testing/myt2xvid3/myt2xvid3.install
@@ -1,6 +1,7 @@
pre_install() {
- echo ""
+ mkdir -p /myth/video/archive
+ chown mythtv:http /myth/video/archive
}
pre_upgrade() {
@@ -13,20 +14,22 @@ pre_remove() {
post_install() {
. /etc/systemconfig
- mkdir /myth/video/archive
- chown mythtv:users /myth/video/archive
ln -s /myth/video/archive /data/srv/httpd/htdocs/archive
+ ln -s /myth/video/archive/archive.php /myth/video/archive/index.php
mv /usr/bin/myt2xvid3 /tmp
sed -e "s/REPLACEME/$HOSTNAME/g" /tmp/myt2xvid3 > /usr/bin/myt2xvid3
chown -R mythtv:http /myth/video/archive
}
post_upgrade() {
- /usr/bin/myth2xvid -rebuild
+ /usr/bin/myt2xvid3 -rebuild
}
post_remove() {
- rm -fr /data/srv/http/htdocs/archive
+ rm -fr /data/srv/http/htdocs/archive
+ rm -rf /myth/video/archive/index.php
+ rm -rf /myth/video/archive/archive.php
+ # don't delete content that the user may still want, so leave /myth/video/archive
}
op=$1