summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/mythappletrailers/mythappletrailers.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
commit116edc0c0cc1b926acce635a76d102408b118a92 (patch)
tree237e661dc7f5b1bb4b18350ab3a48e5a15283851 /abs/extra-testing/mythappletrailers/mythappletrailers.install
parent29e945b91760568116a21e0076fae046b33a2663 (diff)
parent7f42f55d022dc8ca818a76dccfc66fce7c8dea4f (diff)
downloadlinhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.zip
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.gz
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/extra-testing/mythappletrailers/mythappletrailers.install')
-rw-r--r--abs/extra-testing/mythappletrailers/mythappletrailers.install8
1 files changed, 7 insertions, 1 deletions
diff --git a/abs/extra-testing/mythappletrailers/mythappletrailers.install b/abs/extra-testing/mythappletrailers/mythappletrailers.install
index 22dada0..133390c 100644
--- a/abs/extra-testing/mythappletrailers/mythappletrailers.install
+++ b/abs/extra-testing/mythappletrailers/mythappletrailers.install
@@ -1,15 +1,21 @@
# arg 1: the new package version
post_install() {
+ ln -s /home/mythtv/appletrailer.xml /usr/share/mythtv/appletrailer.xml
}
-
# arg 1: the new package version
# arg 2: the old package version
post_upgrade() {
+ if [ -e /usr/share/mythtv/appletrailer.xml ]
+ then
+ exit
+ else
ln -s /home/mythtv/appletrailer.xml /usr/share/mythtv/appletrailer.xml
+ fi
}
# arg 1: the old package version
post_remove() {
+ rm -fr /usr/share/mythtv/appletrailer.xml
}
op=$1