summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/mythvodka/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-02-05 06:45:34 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-02-05 06:45:34 (GMT)
commit1f780b78f0c1f12457a28e7f166c7a9875af33ad (patch)
tree29d14d3a7f4787de850f049497bbade87e563e12 /abs/extra-testing/mythvodka/PKGBUILD
parent4375c7a63a2a702620f8c755843db4c41b1878ce (diff)
downloadlinhes_pkgbuild-1f780b78f0c1f12457a28e7f166c7a9875af33ad.zip
linhes_pkgbuild-1f780b78f0c1f12457a28e7f166c7a9875af33ad.tar.gz
linhes_pkgbuild-1f780b78f0c1f12457a28e7f166c7a9875af33ad.tar.bz2
Adds MythVodka to LinHES.
Diffstat (limited to 'abs/extra-testing/mythvodka/PKGBUILD')
-rw-r--r--abs/extra-testing/mythvodka/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra-testing/mythvodka/PKGBUILD b/abs/extra-testing/mythvodka/PKGBUILD
new file mode 100644
index 0000000..2dbb9ec
--- /dev/null
+++ b/abs/extra-testing/mythvodka/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 5936 2008-07-21 20:24:16Z thomas $
+# Maintainer: Cecil Watson<knoppmyth@gmail.com>
+
+pkgname=mythvodka
+pkgver=0.7
+pkgrel=4
+pkgdesc="MythVodka (Video On Demand Killer App) is a plugin for MythTV allowing streaming of BBC iPlayer, Hulu, HTTP and NZB content."
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://code.google.com/p/mythvodka/"
+depends=('rtmpdump')
+source=('http://mythvodka.googlecode.com/files/mythvodka.07.tar.gz' 'mythvodka.diff' 'hulu_grabber.sh')
+
+build() {
+ patch -p0 < mythvodka.diff
+ cd $startdir/src/mythvodka/mythvodka
+ rm -fr Makefile
+ qmake mythvodka.pro
+ make
+ mkdir -p $startdir/pkg/usr/lib/mythtv/plugins/
+ cp libmythvodka.so $startdir/pkg/usr/lib/mythtv/plugins/
+ strip --strip-unneeded $startdir/pkg/usr/lib/mythtv/plugins/libmythvodka.so
+ mkdir -p $startdir/pkg/usr/share/mythtv/themes/default/
+ cp streams-ui.xml $startdir/pkg/usr/share/mythtv/themes/default/
+ mkdir -p $startdir/pkg/usr/share/mythtv/themes/default-wide/
+ cp theme-wide/streams-ui.xml $startdir/pkg/usr/share/mythtv/themes/default-wide/
+ mkdir -p $startdir/pkg/usr/bin
+ chmod a+x ../scripts/*
+ cp -p ../scripts/* $startdir/pkg/usr/bin
+ mkdir -p $startdir/pkg/etc/cron.daily/
+ chmod 755 ../../hulu_grabber.sh
+ cp ../../hulu_grabber.sh $startdir/pkg/etc/cron.daily/
+}