summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/oss/oss.install
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-02-18 19:19:39 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-02-18 19:19:39 (GMT)
commitdefa55e46b886049bd1de0fdd4cc92410b52d280 (patch)
treeba1c03edb5fa41e03cb49839648697d855a4bdf9 /abs/extra-testing/oss/oss.install
parent416f9c590b6de5de7eeb8eb19b26571626f35a7f (diff)
parent84249e85222f40c8b6855d9822f52d273a3d979f (diff)
downloadlinhes_pkgbuild-defa55e46b886049bd1de0fdd4cc92410b52d280.zip
linhes_pkgbuild-defa55e46b886049bd1de0fdd4cc92410b52d280.tar.gz
linhes_pkgbuild-defa55e46b886049bd1de0fdd4cc92410b52d280.tar.bz2
Merge branch 'master' of nharris@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/oss/oss.install')
-rw-r--r--abs/extra-testing/oss/oss.install38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/extra-testing/oss/oss.install b/abs/extra-testing/oss/oss.install
new file mode 100644
index 0000000..8c4bd0a
--- /dev/null
+++ b/abs/extra-testing/oss/oss.install
@@ -0,0 +1,38 @@
+_MSG_LIBOSSDIR=" Please note that OSS stores some of its configuration files
+ at /usr/lib/oss. If you are upgrading from an older OSS
+ release and it doesn't work properly, try removing that
+ directory and reinstall this package."
+
+post_install() {
+ echo "Creating backup of alsa modules"
+ KER=`uname -r`
+ cd /lib/modules/$KER/kernel
+ tar -cvf /lib/modules/alsa-$KER.tar sound
+ rm -rf sound
+# /bin/sh /usr/lib/oss/build/install.sh &> /dev/null
+ depmod -a
+
+}
+
+post_upgrade() {
+ echo "Running OSS update script..."
+ KER=`uname -r`
+ cd /lib/modules/$KER/kernel
+ if [ -f sound/soundcore.ko ]
+ then
+ tar -cvf /lib/modules/alsa-$KER.tar sound
+ rm -rf sound
+ /bin/true
+ fi
+ depmod -a
+}
+
+pre_remove() {
+
+}
+
+post_remove() {
+
+ /bin/true
+}
+