summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/oss/oss.rc
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-02-18 19:19:39 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-02-18 19:19:39 (GMT)
commitdefa55e46b886049bd1de0fdd4cc92410b52d280 (patch)
treeba1c03edb5fa41e03cb49839648697d855a4bdf9 /abs/extra-testing/oss/oss.rc
parent416f9c590b6de5de7eeb8eb19b26571626f35a7f (diff)
parent84249e85222f40c8b6855d9822f52d273a3d979f (diff)
downloadlinhes_pkgbuild-defa55e46b886049bd1de0fdd4cc92410b52d280.zip
linhes_pkgbuild-defa55e46b886049bd1de0fdd4cc92410b52d280.tar.gz
linhes_pkgbuild-defa55e46b886049bd1de0fdd4cc92410b52d280.tar.bz2
Merge branch 'master' of nharris@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/oss/oss.rc')
-rw-r--r--abs/extra-testing/oss/oss.rc32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/extra-testing/oss/oss.rc b/abs/extra-testing/oss/oss.rc
new file mode 100644
index 0000000..3f63378
--- /dev/null
+++ b/abs/extra-testing/oss/oss.rc
@@ -0,0 +1,32 @@
+#!/bin/bash
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+case "$1" in
+ start)
+ stat_busy 'Starting Open Sound System'
+ if /usr/sbin/soundon
+ then
+ add_daemon oss
+ stat_done
+ else
+ stat_fail
+ fi
+ ;;
+ stop)
+ stat_busy 'Stopping Open Sound System'
+ if /usr/sbin/soundoff
+ then
+ rm_daemon oss
+ stat_done
+ else
+ stat_fail
+ fi
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+esac