summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/pmount/PKGBUILD
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-28 09:08:13 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-28 09:08:13 (GMT)
commit428e5178d79eb900bbe515665b2d6c6a4b0d0f89 (patch)
tree5cf7c10428f1d0afe62eeee70105bd447ea69b99 /abs/extra-testing/pmount/PKGBUILD
parentf6276f03790fc2302054a8242339def7b6792557 (diff)
parent568da1387066e54f0eceb57fd8f53bd0eba87974 (diff)
downloadlinhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.zip
linhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.tar.gz
linhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/pmount/PKGBUILD')
-rw-r--r--abs/extra-testing/pmount/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/extra-testing/pmount/PKGBUILD b/abs/extra-testing/pmount/PKGBUILD
new file mode 100644
index 0000000..2270b07
--- /dev/null
+++ b/abs/extra-testing/pmount/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 29588 2009-03-10 06:17:31Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=pmount
+pkgver=0.9.19
+pkgrel=2
+pkgdesc="mount removable devices as normal user"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://pmount.alioth.debian.org/"
+backup=('etc/pmount.allow')
+depends=('sysfsutils>=2.0.0-1' 'bash' 'hal>=0.5.11')
+makedepends=('intltool')
+source=(http://alioth.debian.org/frs/download.php/2867/${pkgname}-${pkgver}.tar.gz
+ pmount-dbus-close.patch)
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # we have a shared connection! patch it to work correct
+ patch -Np1 -i ${srcdir}/pmount-dbus-close.patch || return 1
+ ./configure --prefix=/usr --with-cryptsetup-prog=/usr/sbin/cryptsetup || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums=('2fd9fe103375dbd0c91af2f302250a8c'
+ 'b7ea1afd82ffebf510dc89f74cd39f09')