summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/pmount/PKGBUILD
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-08-25 16:17:55 (GMT)
committerBob Igo <bob@stormlogic.com>2009-08-25 16:17:55 (GMT)
commitac8a679dad17bc7448d4229f68f5e5c6c703e798 (patch)
treeddf72fcf8dd0e1e3600d3daa58305bbcea3be913 /abs/extra-testing/pmount/PKGBUILD
parent8a9438599b6a623814702b625d11a96e8bbdad69 (diff)
parent6ba090f1282f7a34d5ae396ef4b15610cd22f1c0 (diff)
downloadlinhes_pkgbuild-ac8a679dad17bc7448d4229f68f5e5c6c703e798.zip
linhes_pkgbuild-ac8a679dad17bc7448d4229f68f5e5c6c703e798.tar.gz
linhes_pkgbuild-ac8a679dad17bc7448d4229f68f5e5c6c703e798.tar.bz2
Merge branch 'master' of ssh://knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/pmount/PKGBUILD')
-rw-r--r--abs/extra-testing/pmount/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/extra-testing/pmount/PKGBUILD b/abs/extra-testing/pmount/PKGBUILD
new file mode 100644
index 0000000..2270b07
--- /dev/null
+++ b/abs/extra-testing/pmount/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 29588 2009-03-10 06:17:31Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=pmount
+pkgver=0.9.19
+pkgrel=2
+pkgdesc="mount removable devices as normal user"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://pmount.alioth.debian.org/"
+backup=('etc/pmount.allow')
+depends=('sysfsutils>=2.0.0-1' 'bash' 'hal>=0.5.11')
+makedepends=('intltool')
+source=(http://alioth.debian.org/frs/download.php/2867/${pkgname}-${pkgver}.tar.gz
+ pmount-dbus-close.patch)
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # we have a shared connection! patch it to work correct
+ patch -Np1 -i ${srcdir}/pmount-dbus-close.patch || return 1
+ ./configure --prefix=/usr --with-cryptsetup-prog=/usr/sbin/cryptsetup || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums=('2fd9fe103375dbd0c91af2f302250a8c'
+ 'b7ea1afd82ffebf510dc89f74cd39f09')