summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/policykit-gnome
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
commit116edc0c0cc1b926acce635a76d102408b118a92 (patch)
tree237e661dc7f5b1bb4b18350ab3a48e5a15283851 /abs/extra-testing/policykit-gnome
parent29e945b91760568116a21e0076fae046b33a2663 (diff)
parent7f42f55d022dc8ca818a76dccfc66fce7c8dea4f (diff)
downloadlinhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.zip
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.gz
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/extra-testing/policykit-gnome')
-rw-r--r--abs/extra-testing/policykit-gnome/PKGBUILD32
-rw-r--r--abs/extra-testing/policykit-gnome/policykit-gnome.install23
2 files changed, 55 insertions, 0 deletions
diff --git a/abs/extra-testing/policykit-gnome/PKGBUILD b/abs/extra-testing/policykit-gnome/PKGBUILD
new file mode 100644
index 0000000..e6a7d9c
--- /dev/null
+++ b/abs/extra-testing/policykit-gnome/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: onestep_ua <onestep@ukr.net>
+
+pkgname=policykit-gnome
+pkgver=0.9.2
+pkgrel=2
+pkgdesc="PolicyKit integration for the GNOME desktop"
+arch=('i686' 'x86_64')
+url="http://hal.freedesktop.org/docs/PolicyKit-gnome/"
+license=('GPL')
+depends=('gconf>=2.24.0')
+makedepends=('intltool' 'gtk-doc' 'gnome-doc-utils>=0.14.0')
+options=(!emptydirs !libtool)
+install=${pkgname}.install
+source=(http://hal.freedesktop.org/releases/PolicyKit-gnome-${pkgver}.tar.bz2)
+md5sums=('fc478b168d0c926a9766b0b415ff4bbf')
+
+build() {
+ cd "${srcdir}/PolicyKit-gnome-${pkgver}"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/PolicyKit \
+ --disable-gtk-doc \
+ --disable-examples || return 1
+ make || return 1
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install || return 1
+
+ install -m 755 -d "${pkgdir}/usr/share/gconf/schemas"
+ gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${pkgname}.schemas" ${pkgdir}/etc/gconf/schemas/*.schemas || return 1
+ rm -f ${pkgdir}/etc/gconf/schemas/*.schemas
+}
diff --git a/abs/extra-testing/policykit-gnome/policykit-gnome.install b/abs/extra-testing/policykit-gnome/policykit-gnome.install
new file mode 100644
index 0000000..e2593d3
--- /dev/null
+++ b/abs/extra-testing/policykit-gnome/policykit-gnome.install
@@ -0,0 +1,23 @@
+pkgname=policykit-gnome
+
+## arg 1: the new package version
+post_install() {
+ usr/sbin/gconfpkg --install ${pkgname}
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ pre_remove $1
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+## arg 1: the old package version
+pre_remove() {
+ usr/sbin/gconfpkg --uninstall ${pkgname}
+}