summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/policykit/entry-leak.patch
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
commit525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (patch)
tree35cef28abb613da4f58e83f6abbe4bd4cfa244bf /abs/extra-testing/policykit/entry-leak.patch
parent592e3cad43ef12c53f523145d0fd981b54f2a049 (diff)
parentb172f79fadb565ecfbcec9508f9377d8618a4f4c (diff)
downloadlinhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.zip
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.gz
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/policykit/entry-leak.patch')
-rw-r--r--abs/extra-testing/policykit/entry-leak.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/abs/extra-testing/policykit/entry-leak.patch b/abs/extra-testing/policykit/entry-leak.patch
deleted file mode 100644
index f6b3295..0000000
--- a/abs/extra-testing/policykit/entry-leak.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -up PolicyKit-0.9/src/polkit/polkit-policy-file-entry.c.entry-leak PolicyKit-0.9/src/polkit/polkit-policy-file-entry.c
---- PolicyKit-0.9/src/polkit/polkit-policy-file-entry.c.entry-leak 2008-08-29 21:47:22.000000000 -0400
-+++ PolicyKit-0.9/src/polkit/polkit-policy-file-entry.c 2008-08-29 21:50:13.000000000 -0400
-@@ -95,9 +95,11 @@ _polkit_policy_file_entry_new (const c
- char *contents;
- size_t contents_size;
- PolKitPolicyFileEntry *pfe;
-+ char **tokens;
-
- path = NULL;
- contents = NULL;
-+ tokens = NULL;
-
- kit_return_val_if_fail (action_id != NULL && polkit_action_validate_id (action_id), NULL);
-
-@@ -153,7 +155,6 @@ _polkit_policy_file_entry_new (const c
- }
-
- if (contents != NULL) {
-- char **tokens;
- size_t num_tokens;
- PolKitResult any;
- PolKitResult inactive;
-@@ -183,11 +184,13 @@ _polkit_policy_file_entry_new (const c
-
- kit_free (path);
- kit_free (contents);
-+ kit_strfreev (tokens);
-
- return pfe;
- error:
- kit_free (path);
- kit_free (contents);
-+ kit_strfreev (tokens);
- if (pfe != NULL)
- polkit_policy_file_entry_unref (pfe);
- return NULL;