summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/pygtk
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-04 18:49:24 (GMT)
commit116edc0c0cc1b926acce635a76d102408b118a92 (patch)
tree237e661dc7f5b1bb4b18350ab3a48e5a15283851 /abs/extra-testing/pygtk
parent29e945b91760568116a21e0076fae046b33a2663 (diff)
parent7f42f55d022dc8ca818a76dccfc66fce7c8dea4f (diff)
downloadlinhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.zip
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.gz
linhes_pkgbuild-116edc0c0cc1b926acce635a76d102408b118a92.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/extra-testing/pygtk')
-rw-r--r--abs/extra-testing/pygtk/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra-testing/pygtk/PKGBUILD b/abs/extra-testing/pygtk/PKGBUILD
new file mode 100644
index 0000000..434af1c
--- /dev/null
+++ b/abs/extra-testing/pygtk/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 16726 2008-10-22 02:50:46Z allan $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
+
+pkgname=pygtk
+pkgver=2.13.0
+pkgrel=2
+pkgdesc="Python bindings for the GTK widget set"
+arch=(i686 x86_64)
+license=('LGPL')
+depends=('libglade>=2.6.3' 'pycairo>=1.6.4' 'pygobject>=2.15.4' 'python-numeric>=24.2-2')
+options=('!libtool')
+url="http://www.pygtk.org/"
+source=(http://ftp.gnome.org/pub/gnome/sources/pygtk/2.13/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('e1513921bfd3790b456899c483fceaea')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m644 gtk/gtk-extrafuncs.defs "${pkgdir}/usr/share/pygtk/2.0/defs/" || return 1
+}