summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/strace/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-09 22:26:06 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-09 22:26:06 (GMT)
commitf0bec092221a05080d9fca9ffbf9d7cc04c7ceda (patch)
tree8183228c7c08b78e76279576d8df97548f2a61f7 /abs/extra-testing/strace/PKGBUILD
parentf18e8e6b49cb7922576619b00f75f18ff2886efc (diff)
downloadlinhes_pkgbuild-f0bec092221a05080d9fca9ffbf9d7cc04c7ceda.zip
linhes_pkgbuild-f0bec092221a05080d9fca9ffbf9d7cc04c7ceda.tar.gz
linhes_pkgbuild-f0bec092221a05080d9fca9ffbf9d7cc04c7ceda.tar.bz2
add in strace
Diffstat (limited to 'abs/extra-testing/strace/PKGBUILD')
-rw-r--r--abs/extra-testing/strace/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/abs/extra-testing/strace/PKGBUILD b/abs/extra-testing/strace/PKGBUILD
new file mode 100644
index 0000000..c965f24
--- /dev/null
+++ b/abs/extra-testing/strace/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 13699 2008-09-27 22:25:37Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+pkgname=strace
+pkgver=4.5.18
+pkgrel=1
+pkgdesc="A useful diagnositic, instructional, and debugging tool"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://sourceforge.net/projects/strace/"
+depends=('glibc')
+source=(http://downloads.sourceforge.net/sourceforge/strace/strace-$pkgver.tar.bz2)
+md5sums=('e9449fcee97e6a8ed73934c883c870e0')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ install -Dm644 COPYRIGHT ${startdir}/pkg/usr/share/licenses/strace/COPYRIGHT
+}