summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/v4l-dvb-dvico2/v4l-dvb.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-09 14:15:17 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-09 14:15:17 (GMT)
commit9a44255ba27e549106e4199cda5d30e1a5035f76 (patch)
tree8b47cffe9e36e733d3d52ff9b61a9d16f1f78b4d /abs/extra-testing/v4l-dvb-dvico2/v4l-dvb.install
parentdbfd9598e7acac8ad2ad8b9501859d07a51ae4e6 (diff)
parent1d197919d5899c4a133e609116fec381157bc870 (diff)
downloadlinhes_pkgbuild-9a44255ba27e549106e4199cda5d30e1a5035f76.zip
linhes_pkgbuild-9a44255ba27e549106e4199cda5d30e1a5035f76.tar.gz
linhes_pkgbuild-9a44255ba27e549106e4199cda5d30e1a5035f76.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/extra-testing/v4l-dvb-dvico2/v4l-dvb.install')
-rw-r--r--abs/extra-testing/v4l-dvb-dvico2/v4l-dvb.install23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra-testing/v4l-dvb-dvico2/v4l-dvb.install b/abs/extra-testing/v4l-dvb-dvico2/v4l-dvb.install
new file mode 100644
index 0000000..c87bb82
--- /dev/null
+++ b/abs/extra-testing/v4l-dvb-dvico2/v4l-dvb.install
@@ -0,0 +1,23 @@
+# arg 1: the new package version
+post_install() {
+ KERNEL_VERSION='2.6.26-ARCH'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ KERNEL_VERSION='2.6.26-ARCH'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+
+}
+
+# arg 1: the old package version
+post_remove() {
+ KERNEL_VERSION='2.6.26-ARCH'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+}
+
+op=$1
+shift
+$op $*