summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/v4l-dvb-hdpvr
diff options
context:
space:
mode:
authorTom Culliton <culliton@x2.(none)>2009-01-11 06:39:13 (GMT)
committerTom Culliton <culliton@x2.(none)>2009-01-11 06:39:13 (GMT)
commitbe39c7ab3a0d4665f5e0ed4bb2571e006dc759b3 (patch)
tree246cd99370e2d7482d0049b3b71962486925890a /abs/extra-testing/v4l-dvb-hdpvr
parenteb00fec42b6ccd143a145c89fff284969aa738be (diff)
parentc18b7a805648a5920424454ec5237d699ce4eecc (diff)
downloadlinhes_pkgbuild-be39c7ab3a0d4665f5e0ed4bb2571e006dc759b3.zip
linhes_pkgbuild-be39c7ab3a0d4665f5e0ed4bb2571e006dc759b3.tar.gz
linhes_pkgbuild-be39c7ab3a0d4665f5e0ed4bb2571e006dc759b3.tar.bz2
Merge branch 'master' of tjc@linhes.org:LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/v4l-dvb-hdpvr')
-rw-r--r--abs/extra-testing/v4l-dvb-hdpvr/PKGBUILD27
-rw-r--r--abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install23
2 files changed, 50 insertions, 0 deletions
diff --git a/abs/extra-testing/v4l-dvb-hdpvr/PKGBUILD b/abs/extra-testing/v4l-dvb-hdpvr/PKGBUILD
new file mode 100644
index 0000000..d10c398
--- /dev/null
+++ b/abs/extra-testing/v4l-dvb-hdpvr/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 5936 2008-07-21 20:24:16Z thomas $
+# Maintainer: Cecil Watson<knoppmyth@gmail.com>
+
+pkgname=v4l-dvb-hdpvr
+_kernver=2.6.26-ARCH
+pkgver=1
+pkgrel=1
+pkgdesc="V4L-DVB drivers for HD-PVR from mercurial"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://linuxtv.org/"
+depends=('kernel26')
+replaces=(v4l-dvb)
+makedepends=(kernel-headers)
+install=v4l-dvb-hdpvr.install
+source=()
+
+build() {
+ cd $startdir/src/
+ hg clone http://hg.jannau.net/hdpvr/ || return 1
+ cd hdpvr
+ make KERNDIR=/lib/modules/$_kernver/build \
+ DESTDIR=$startdir/pkg KERNELRELEASE=$_kernver all || return 1
+ make KERNDIR=/lib/modules/$_kernver/build \
+ DESTDIR=$startdir/pkg KERNELRELEASE=$_kernver install || return 1
+ rm -fr $startdir/pkg/lib/modules/$_kernver/modules*
+}
diff --git a/abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install b/abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install
new file mode 100644
index 0000000..c87bb82
--- /dev/null
+++ b/abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install
@@ -0,0 +1,23 @@
+# arg 1: the new package version
+post_install() {
+ KERNEL_VERSION='2.6.26-ARCH'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ KERNEL_VERSION='2.6.26-ARCH'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+
+}
+
+# arg 1: the old package version
+post_remove() {
+ KERNEL_VERSION='2.6.26-ARCH'
+ depmod -ae -v $KERNEL_VERSION > /dev/null 2>&1
+}
+
+op=$1
+shift
+$op $*