summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/wol
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
commitc38715641e214272ad7dc6d495edd29940366e7f (patch)
tree9dcd507543e67458d98fa7462f62026041524047 /abs/extra-testing/wol
parent3d91b06198a56b6579cb0bd77de65f5908571b87 (diff)
downloadlinhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.zip
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.gz
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.bz2
packages that will be needed in the future.
This is the initial merge of packages from MythVantage that are not MythVantage specific.
Diffstat (limited to 'abs/extra-testing/wol')
-rwxr-xr-xabs/extra-testing/wol/PKGBUILD19
-rwxr-xr-xabs/extra-testing/wol/wakeonlan.sh10
2 files changed, 29 insertions, 0 deletions
diff --git a/abs/extra-testing/wol/PKGBUILD b/abs/extra-testing/wol/PKGBUILD
new file mode 100755
index 0000000..1981453
--- /dev/null
+++ b/abs/extra-testing/wol/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Markus Volkmann <mcfock@counterstrike.de>
+pkgname=wol
+pkgver=0.7.1
+pkgrel=2
+pkgdesc="wol implements Wake On LAN functionality in a small program. It wakes up hardware that is Magic Packet compliant."
+license="GPL"
+url="http://ahh.sourceforge.net/wol/"
+arch=('i686')
+source=(http://easynews.dl.sourceforge.net/sourceforge/ahh/wol-$pkgver.tar.gz wakeonlan.sh)
+md5sums=('c2fa9d7e771134ac8c89d56b8197d4ca')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make prefix=$startdir/pkg/usr install
+ install -m755 $startdir/src/wakeonlan.sh $startdir/pkg/usr/bin/wakeonlan.sh
+}
+
diff --git a/abs/extra-testing/wol/wakeonlan.sh b/abs/extra-testing/wol/wakeonlan.sh
new file mode 100755
index 0000000..f87dd34
--- /dev/null
+++ b/abs/extra-testing/wol/wakeonlan.sh
@@ -0,0 +1,10 @@
+#!/bin/bash
+DIR="/data/srv/hobbit/var/hostdata/$1"
+FILE=`ls -t --group-directories-first $DIR|tail -n 1`
+for mac in `grep HW "$DIR/$FILE" |awk '{ print $5 } '`
+do
+ /usr/bin/wol -v $mac
+done
+
+
+