summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/wxgtk/gsocket.patch
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-03-22 19:37:16 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-03-22 19:37:16 (GMT)
commit21383e4ca51bc151601a51e6d75885959deb89e1 (patch)
treef9c1e3739098b700c0e0421c069ae926cc1b8cc2 /abs/extra-testing/wxgtk/gsocket.patch
parentdbff62a9a2550bd0bed77860fa4164d74c90dfb3 (diff)
parente51cf415764a2c267f373965c48eec082ad59d81 (diff)
downloadlinhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.zip
linhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.tar.gz
linhes_pkgbuild-21383e4ca51bc151601a51e6d75885959deb89e1.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/wxgtk/gsocket.patch')
-rw-r--r--abs/extra-testing/wxgtk/gsocket.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/abs/extra-testing/wxgtk/gsocket.patch b/abs/extra-testing/wxgtk/gsocket.patch
new file mode 100644
index 0000000..0f1fc7b
--- /dev/null
+++ b/abs/extra-testing/wxgtk/gsocket.patch
@@ -0,0 +1,18 @@
+Index: 2.8/src/gtk/gsockgtk.cpp
+===================================================================
+--- 2.8/src/gtk/gsockgtk.cpp (revision 60599)
++++ 2.8/src/gtk/gsockgtk.cpp (working copy)
+@@ -15,8 +15,13 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+
++// newer versions of glib define its own GSocket but we unfortunately use this
++// name in our own (semi-)public header and so can't change it -- rename glib
++// one instead
++#define GSocket GlibGSocket
+ #include <gdk/gdk.h>
+ #include <glib.h>
++#undef GSocket
+
+ #include "wx/gsocket.h"
+ #include "wx/unix/gsockunx.h"