summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/xe/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-02-04 06:59:16 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-02-04 06:59:16 (GMT)
commit1381cb92cc0e3bcf1adf11c0aa9d94abcab91d5b (patch)
tree95686e9b760906525e8778944af8c7d9eb323d8b /abs/extra-testing/xe/PKGBUILD
parentb51150cb7b21d9040857fef6ad5fa0d934ac427d (diff)
downloadlinhes_pkgbuild-1381cb92cc0e3bcf1adf11c0aa9d94abcab91d5b.zip
linhes_pkgbuild-1381cb92cc0e3bcf1adf11c0aa9d94abcab91d5b.tar.gz
linhes_pkgbuild-1381cb92cc0e3bcf1adf11c0aa9d94abcab91d5b.tar.bz2
Initial inclusion of XE multi-system emulator.
Diffstat (limited to 'abs/extra-testing/xe/PKGBUILD')
-rw-r--r--abs/extra-testing/xe/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/abs/extra-testing/xe/PKGBUILD b/abs/extra-testing/xe/PKGBUILD
new file mode 100644
index 0000000..e87d7a3
--- /dev/null
+++ b/abs/extra-testing/xe/PKGBUILD
@@ -0,0 +1,19 @@
+# $Id: PKGBUILD 5936 2008-07-21 20:24:16Z thomas $
+# Maintainer: Cecil Watson<knoppmyth@gmail.com>
+
+pkgname=xe
+pkgver=2.16.1
+pkgrel=1
+pkgdesc="A multi system emulator, that emulates many console and handheld video game systems."
+arch=('i686' 'x86_64')
+url="http://www.xe-emulator.com"
+source=(http://www.xe-emulator.com/files/xe-x86-32-bin.2.16.1.tar.bz2)
+install=xe.install
+build() {
+ cd $startdir/src/xe-x86
+ make
+ mkdir -p $startdir/pkg/usr/bin
+ mkdir -p $startdir/pkg/usr/lib/xe
+ mkdir -p $startdir/pkg/usr/lib/xe/bios
+ cp -rf xe modules rc manual.html $startdir/pkg/usr/lib/xe
+}