summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/xfsdump
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-02 01:38:35 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-02 01:38:35 (GMT)
commitf0d6782b822b8637d733aab1bd915b15cb85353e (patch)
treeee74f1e5bf34c9c553a0df7fc5f55b9b59a3542f /abs/extra-testing/xfsdump
parent3820afa956644f52e2f454bc2ee03e41a3238558 (diff)
parent8bc928907e616b695413f9dbb1f6aaa56d56cc33 (diff)
downloadlinhes_pkgbuild-f0d6782b822b8637d733aab1bd915b15cb85353e.zip
linhes_pkgbuild-f0d6782b822b8637d733aab1bd915b15cb85353e.tar.gz
linhes_pkgbuild-f0d6782b822b8637d733aab1bd915b15cb85353e.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/xfsdump')
-rw-r--r--abs/extra-testing/xfsdump/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/extra-testing/xfsdump/PKGBUILD b/abs/extra-testing/xfsdump/PKGBUILD
new file mode 100644
index 0000000..1d40228
--- /dev/null
+++ b/abs/extra-testing/xfsdump/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 26569 2009-02-09 18:40:22Z paul $
+# Maintainer: judd <jvinet@zeroflux.org>
+pkgname=xfsdump
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Additional XFS filesystem utilities"
+arch=(i686 x86_64)
+license=('LGPL')
+url="http://oss.sgi.com/projects/xfs/"
+depends=('xfsprogs>=3.0.0' 'attr>=2.4.39' 'acl>=2.2.45' 'dmapi')
+options=('!makeflags')
+source=(ftp://oss.sgi.com/projects/xfs/cmd_tars/xfsdump-${pkgver}.tar.gz)
+md5sums=('')
+options=(!emptydirs)
+
+build() {
+ cd $startdir/src/xfsdump-$pkgver
+ autoconf
+ ./configure --prefix=/usr
+ make || return 1
+ make prefix=$startdir/pkg/usr install
+ # fixes
+ rm -f $startdir/pkg/usr/lib/*.la
+ rm -f $startdir/pkg/usr/bin/{xfsdump,xfsrestore}
+}