summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/xmms/xmms-fix.diff
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-01-17 17:54:02 (GMT)
committerBob Igo <bob@stormlogic.com>2009-01-17 17:54:02 (GMT)
commit100e02faeb525e8f697b0c8c6bc4a3eb2179c8b3 (patch)
tree720dc08fc5feddfd8934ecdcd79fdd703922956e /abs/extra-testing/xmms/xmms-fix.diff
parent18b8c17f24b9cd6d9600b212cbd615deb69fe500 (diff)
parentcff24d02505081b7297a257c38edcf286772e015 (diff)
downloadlinhes_pkgbuild-100e02faeb525e8f697b0c8c6bc4a3eb2179c8b3.zip
linhes_pkgbuild-100e02faeb525e8f697b0c8c6bc4a3eb2179c8b3.tar.gz
linhes_pkgbuild-100e02faeb525e8f697b0c8c6bc4a3eb2179c8b3.tar.bz2
Merge branch 'master' of ssh://igo@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing/xmms/xmms-fix.diff')
-rw-r--r--abs/extra-testing/xmms/xmms-fix.diff11
1 files changed, 11 insertions, 0 deletions
diff --git a/abs/extra-testing/xmms/xmms-fix.diff b/abs/extra-testing/xmms/xmms-fix.diff
new file mode 100644
index 0000000..a810aa2
--- /dev/null
+++ b/abs/extra-testing/xmms/xmms-fix.diff
@@ -0,0 +1,11 @@
+--- xmms-1.2.10+cvs20060429/xmms/util.c.orig 2006-11-05 12:29:59.000000000 +0800
++++ xmms-1.2.10+cvs20060429/xmms/util.c 2006-11-05 12:30:01.000000000 +0800
+@@ -175,7 +175,7 @@ GdkImage *create_dblsize_image(GdkImage
+ * This needs to be optimized
+ */
+
+- dblimg = gdk_image_new(GDK_IMAGE_NORMAL, gdk_visual_get_best(), img->width << 1, img->height << 1);
++ dblimg = gdk_image_new(GDK_IMAGE_NORMAL, gdk_visual_get_best_with_depth(img->depth), img->width << 1, img->height << 1);
+ if (dblimg->bpp == 1)
+ {
+ register guint8 *srcptr, *ptr, *ptr2, pix;