summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/xulrunner/nsThreadUtils.patch
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-01 03:14:54 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-01 03:14:54 (GMT)
commit7b35632e80f168d8c5f2220bf610ee7e24b81270 (patch)
tree8facf3fa565911f056a08e38f6a5eed0f756f9c6 /abs/extra-testing/xulrunner/nsThreadUtils.patch
parent7e10f51870aa10be3b35d7912a7b54e30f608bb8 (diff)
parent7accc0f042acdfdca9f067b1d4011d6ac01b1a74 (diff)
downloadlinhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.zip
linhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.tar.gz
linhes_pkgbuild-7b35632e80f168d8c5f2220bf610ee7e24b81270.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/extra-testing/xulrunner/nsThreadUtils.patch')
-rw-r--r--abs/extra-testing/xulrunner/nsThreadUtils.patch42
1 files changed, 0 insertions, 42 deletions
diff --git a/abs/extra-testing/xulrunner/nsThreadUtils.patch b/abs/extra-testing/xulrunner/nsThreadUtils.patch
deleted file mode 100644
index 69609c0..0000000
--- a/abs/extra-testing/xulrunner/nsThreadUtils.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- xulrunner-1.9.0.4.orig/xpcom/glue/nsThreadUtils.cpp
-+++ xulrunner-1.9.0.4/xpcom/glue/nsThreadUtils.cpp
-@@ -187,24 +187,27 @@
- }
- #endif // XPCOM_GLUE_AVOID_NSPR
-
-+inline PRBool
-+hasPendingEvents(nsIThread *thread)
-+{
-+ PRBool val;
-+ return NS_SUCCEEDED(thread->HasPendingEvents(&val)) && val;
-+}
-+
- PRBool
- NS_HasPendingEvents(nsIThread *thread)
- {
--#ifdef MOZILLA_INTERNAL_API
- if (!thread) {
-+#ifndef MOZILLA_INTERNAL_API
-+ nsCOMPtr<nsIThread> current;
-+ NS_GetCurrentThread(getter_AddRefs(current));
-+ return hasPendingEvents(current);
-+#else
- thread = NS_GetCurrentThread();
- NS_ENSURE_TRUE(thread, PR_FALSE);
-- }
--#else
-- nsCOMPtr<nsIThread> current;
-- if (!thread) {
-- NS_GetCurrentThread(getter_AddRefs(current));
-- NS_ENSURE_TRUE(current, PR_FALSE);
-- thread = current.get();
-- }
- #endif
-- PRBool val;
-- return NS_SUCCEEDED(thread->HasPendingEvents(&val)) && val;
-+ }
-+ return hasPendingEvents(thread);
- }
-
- PRBool
-