summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/xulrunner
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-07-29 09:29:30 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-07-29 09:29:30 (GMT)
commit4159bd66e3adbf81679c68dfbe6a01486a3f53db (patch)
tree01bd3c6700bce3d19f053d900598cac1df63fcb9 /abs/extra-testing/xulrunner
parentfd40ea704a335d923d7af765add1b3bad1ee5a9d (diff)
downloadlinhes_pkgbuild-4159bd66e3adbf81679c68dfbe6a01486a3f53db.zip
linhes_pkgbuild-4159bd66e3adbf81679c68dfbe6a01486a3f53db.tar.gz
linhes_pkgbuild-4159bd66e3adbf81679c68dfbe6a01486a3f53db.tar.bz2
firefox3.5.1upgrade: firefox nss nspr sqlite3 xulrunner
Diffstat (limited to 'abs/extra-testing/xulrunner')
-rw-r--r--abs/extra-testing/xulrunner/100-system-hunspell-corrections.patch116
-rw-r--r--abs/extra-testing/xulrunner/PKGBUILD45
-rw-r--r--abs/extra-testing/xulrunner/bzXXX_pc_honour_system_nspr_nss.patch114
-rw-r--r--abs/extra-testing/xulrunner/fix-mozilla-launcher.patch23
-rw-r--r--abs/extra-testing/xulrunner/mozilla-pkgconfig.patch88
-rw-r--r--abs/extra-testing/xulrunner/mozilla-ps-pdf-simplify-operators.patch42
-rw-r--r--abs/extra-testing/xulrunner/nsThreadUtils.patch42
7 files changed, 8 insertions, 462 deletions
diff --git a/abs/extra-testing/xulrunner/100-system-hunspell-corrections.patch b/abs/extra-testing/xulrunner/100-system-hunspell-corrections.patch
deleted file mode 100644
index 5533e10..0000000
--- a/abs/extra-testing/xulrunner/100-system-hunspell-corrections.patch
+++ /dev/null
@@ -1,116 +0,0 @@
---- ./extensions/spellcheck/hunspell/src/mozHunspell.cpp.orig 2008-02-15 19:21:21.000000000 +0000
-+++ ./extensions/spellcheck/hunspell/src/mozHunspell.cpp 2008-02-15 19:23:20.000000000 +0000
-@@ -63,6 +63,9 @@
- #include "nsISimpleEnumerator.h"
- #include "nsIDirectoryEnumerator.h"
- #include "nsIFile.h"
-+#ifdef MOZ_NATIVE_HUNSPELL
-+#include "nsILocalFile.h"
-+#endif
- #include "nsDirectoryServiceUtils.h"
- #include "nsDirectoryServiceDefs.h"
- #include "mozISpellI18NManager.h"
-@@ -307,7 +310,16 @@
- return;
-
- nsCOMPtr<nsIFile> dictDir;
-- rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY,
-+ #ifdef MOZ_NATIVE_HUNSPELL
-+ nsCOMPtr<nsILocalFile> localFile;
-+ rv = NS_NewNativeLocalFile(nsDependentCString("/usr/share/myspell"),PR_TRUE, getter_AddRefs(localFile));
-+ if (localFile && NS_SUCCEEDED(rv)) {
-+ localFile->QueryInterface(NS_GET_IID(nsIFile), getter_AddRefs(dictDir));
-+ LoadDictionariesFromDir(dictDir);
-+ }
-+ else {
-+ #endif
-+ rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY,
- NS_GET_IID(nsIFile), getter_AddRefs(dictDir));
- if (NS_SUCCEEDED(rv)) {
- LoadDictionariesFromDir(dictDir);
-@@ -332,6 +344,9 @@
- LoadDictionariesFromDir(appDir);
- }
- }
-+#ifdef MOZ_NATIVE_HUNSPELL
-+ }
-+#endif
-
- nsCOMPtr<nsISimpleEnumerator> dictDirs;
- rv = dirSvc->Get(DICTIONARY_SEARCH_DIRECTORY_LIST,
---- ./extensions/spellcheck/src/Makefile.in.orig 2008-02-15 19:25:58.000000000 +0000
-+++ ./extensions/spellcheck/src/Makefile.in 2008-02-15 19:28:36.000000000 +0000
-@@ -63,9 +63,16 @@
- txtsvc \
- uconv \
- unicharutil \
-+ xulapp \
- $(NULL)
-
--CPPSRCS = \
-+ifdef MOZ_NATIVE_HUNSPELL
-+CPPSRCS += mozHunspell.cpp
-+ifdef MOZ_XUL_APP
-+CPPSRCS += mozHunspellDirProvider.cpp
-+endif
-+endif
-+CPPSRCS += \
- mozSpellCheckerFactory.cpp \
- mozSpellChecker.cpp \
- mozPersonalDictionary.cpp \
-@@ -80,8 +87,14 @@
- SHARED_LIBRARY_LIBS += ../osxspell/src/$(LIB_PREFIX)osxspell_s.$(LIB_SUFFIX)
- LOCAL_INCLUDES += -I$(srcdir)/../osxspell/src
- else
-+ifndef MOZ_NATIVE_HUNSPELL
- SHARED_LIBRARY_LIBS += ../hunspell/src/$(LIB_PREFIX)hunspell_s.$(LIB_SUFFIX)
- LOCAL_INCLUDES += -I$(srcdir)/../hunspell/src
-+else
-+LOCAL_INCLUDES += $(MOZ_HUNSPELL_CFLAGS) \
-+ -DMOZ_NATIVE_HUNSPELL \
-+ $(NULL)
-+endif
- endif
-
- EXTRA_DSO_LDOPTS = \
-@@ -96,3 +112,18 @@
- LOCAL_INCLUDES += \
- -I$(topsrcdir)/xpcom/io \
- $(NULL)
-+
-+ifdef MOZ_NATIVE_HUNSPELL
-+export:: $(srcdir)/../hunspell/src/mozHunspell.cpp
-+ $(INSTALL) $(srcdir)/../hunspell/src/mozHunspell.* .
-+GARBAGE += mozHunspell.$(OBJ_SUFFIX) mozHunspell.cpp
-+clean::
-+ rm -f mozHunspell.*
-+ifdef MOZ_XUL_APP
-+export:: $(srcdir)/../hunspell/src/mozHunspellDirProvider.cpp
-+ $(INSTALL) $(srcdir)/../hunspell/src/mozHunspellDirProvider.* .
-+GARBAGE += mozHunspellDirProvider.$(OBJ_SUFFIX) mozHunspellDirProvider.cpp
-+clean::
-+ rm -f mozHunspellDirProvider.*
-+endif
-+endif
---- ./extensions/spellcheck/Makefile.in.orig 2008-02-15 19:23:39.000000000 +0000
-+++ ./extensions/spellcheck/Makefile.in 2008-02-15 19:24:34.000000000 +0000
-@@ -42,13 +42,19 @@
- include $(DEPTH)/config/autoconf.mk
-
- MODULE = spellchecker
--DIRS = idl locales
-+ifndef MOZ_NATIVE_HUNSPELL
-+DIRS = idl locales
-+else
-+DIRS = idl
-+endif
-
- ifeq (camino,$(MOZ_BUILD_APP))
- DIRS += osxspell
- else
-+ifndef MOZ_NATIVE_HUNSPELL
- DIRS += hunspell
- endif
-+endif
-
- DIRS += src
diff --git a/abs/extra-testing/xulrunner/PKGBUILD b/abs/extra-testing/xulrunner/PKGBUILD
index 3f3f757..84d6734 100644
--- a/abs/extra-testing/xulrunner/PKGBUILD
+++ b/abs/extra-testing/xulrunner/PKGBUILD
@@ -2,56 +2,27 @@
# Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=xulrunner
-pkgver=1.9.0.9
-_ffoxver=3.0.9
+pkgver=1.9.1.1
+_ffoxver=3.5.1
pkgrel=2
pkgdesc="Mozilla Runtime Environment"
arch=(i686 x86_64)
license=('MPL' 'GPL' 'LGPL')
-depends=('gtk2>=2.16.0' 'gcc-libs>=4.3.3' 'libidl2>=0.8.13' 'mozilla-common' 'nss>=3.12.2' 'libxt' 'lcms' 'hunspell>=1.2.8' 'startup-notification>=0.9')
+depends=('gtk2>=2.16.0' 'gcc-libs>=4.3.3' 'libidl2>=0.8.13' 'mozilla-common' 'nss>=3.12.3' 'libxt' 'lcms'
+ 'hunspell>=1.2.8' 'startup-notification>=0.9')
makedepends=('zip' 'pkgconfig' 'diffutils' 'libgnomeui>=2.24.1')
provides=(gecko-sdk)
replaces=(gecko-sdk)
url="http://wiki.mozilla.org/XUL:Xul_Runner"
source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}/source/firefox-${_ffoxver}-source.tar.bz2
- mozconfig
- 100-system-hunspell-corrections.patch
- bzXXX_pc_honour_system_nspr_nss.patch
- mozilla-pkgconfig.patch
- fix-mozilla-launcher.patch
- mozilla-ps-pdf-simplify-operators.patch
- nsThreadUtils.patch)
-md5sums=('f80b085699db8201e5db6b30fc63c60d'
- '6509d12e6b17bfc51c09e1dc35259035'
- '5efd6772ed0ecf8eddec5d5650191d3c'
- '7a5151f90cb360bc1ea911e5cf7208e9'
- 'dfbfb4e35912112668ac66dae0783686'
- '63eee2d1da3b43c9d604f2253f242f40'
- '13dca58c04e62a8916691c63c5c492a0'
- 'ccc3a0672c783c043434f256fbd38c86')
+ mozconfig)
+md5sums=('18169e189785d680827d4fce94524449'
+ '6509d12e6b17bfc51c09e1dc35259035')
build() {
- cd ${startdir}/src/mozilla
+ cd ${startdir}/src/mozilla-1.9.1
cp ${startdir}/src/mozconfig .mozconfig
- #Upstream patch. Still not applied to 1.9.0.1
- patch -Np1 -i ${srcdir}/mozilla-ps-pdf-simplify-operators.patch || return 1
-
- #fix build with system hunspell - gentoo
- patch -Np0 -i ${srcdir}/100-system-hunspell-corrections.patch || return 1
-
- #fix pkgconfig files when building with system nss/nspr - ubuntu
- patch -Np1 -i ${srcdir}/bzXXX_pc_honour_system_nspr_nss.patch || return 1
-
- #fix libdir/sdkdir - fedora - with local modifications
- patch -Np1 -i ${srcdir}/mozilla-pkgconfig.patch || return 1
-
- #Fix stub launcher - archlinux
- patch -Np0 -i ${srcdir}/fix-mozilla-launcher.patch || return 1
-
- #Fix epiphany crashes - requires epiphany rebuild
- patch -Np1 -i ${srcdir}/nsThreadUtils.patch || return 1
-
unset CFLAGS
unset CXXFLAGS
export LDFLAGS="-Wl,-rpath,/usr/lib/xulrunner-1.9"
diff --git a/abs/extra-testing/xulrunner/bzXXX_pc_honour_system_nspr_nss.patch b/abs/extra-testing/xulrunner/bzXXX_pc_honour_system_nspr_nss.patch
deleted file mode 100644
index be2e872..0000000
--- a/abs/extra-testing/xulrunner/bzXXX_pc_honour_system_nspr_nss.patch
+++ /dev/null
@@ -1,114 +0,0 @@
----
- xulrunner/installer/Makefile.in | 17 ++++++++++++++---
- xulrunner/installer/libxul-embedding-unstable.pc.in | 2 +-
- xulrunner/installer/libxul-embedding.pc.in | 2 +-
- xulrunner/installer/mozilla-nss.pc.in | 6 +++---
- 4 files changed, 19 insertions(+), 8 deletions(-)
-
-Index: mozilla/xulrunner/installer/Makefile.in
-===================================================================
---- mozilla.orig/xulrunner/installer/Makefile.in
-+++ mozilla/xulrunner/installer/Makefile.in
-@@ -90,40 +90,51 @@
- mozilla-plugin.pc \
- mozilla-gtkmozembed.pc \
- mozilla-gtkmozembed-embedding.pc \
- $(NULL)
-
- ifdef MOZ_NATIVE_NSPR
- NSPR_NAME=nspr
- NSPR_VERSION=$(shell $(NSPR_CONFIG) --version)
-+FULL_NSPR_CFLAGS=$(shell $(NSPR_CONFIG) --cflags)
-+FULL_NSPR_LIBS=$(shell $(NSPR_CONFIG) --libs)
- else
--pkg_config_files += mozilla-nspr.pc
- NSPR_NAME=mozilla-nspr
- FULL_NSPR_CFLAGS=-I\$${includedir}/stable
- FULL_NSPR_LIBS=$(subst $(prefix),\$${sdkdir},$(shell $(DEPTH)/nsprpub/config/nspr-config --libs))
- NSPR_VERSION=$(shell $(DEPTH)/nsprpub/config/nspr-config --version)
- endif
-+pkg_config_files += mozilla-nspr.pc
-
- $(warning FULL_NSPR_CFLAGS=$(FULL_NSPR_CFLAGS))
-
--ifndef MOZ_NATIVE_NSS
--pkg_config_files += mozilla-nss.pc
-+ifdef MOZ_NATIVE_NSS
-+NSS_VERSION=$(shell $(NSS_CONFIG) --version)
-+FULL_NSS_CFLAGS=$(shell $(NSS_CONFIG) --cflags)
-+FULL_NSS_LIBS=$(shell $(NSS_CONFIG) --libs)
-+else
-+NSS_VERSION=$(shell $(DEPTH)/nsprpub/config/nss-config --version)
-+FULL_NSS_CFLAGS=-I\$${includedir}/stable
-+FULL_NSS_LIBS=$(subst $(prefix),\$${sdkdir},$(shell $(DEPTH)/nsprpub/config/nss-config --libs))
- endif
-+pkg_config_files += mozilla-nss.pc
-
- %.pc: $(srcdir)/%.pc.in Makefile.in Makefile $(DEPTH)/config/autoconf.mk
- cat $< | sed \
- -e "s|%prefix%|$(prefix)|" \
- -e "s|%includedir%|$(includedir)|" \
- -e "s|%idldir%|$(idldir)|" \
- -e "s|%sdkdir%|$(sdkdir)|" \
- -e "s|%MOZ_APP_NAME%|$(MOZ_APP_NAME)|" \
- -e "s|%MOZILLA_VERSION%|$(MOZ_APP_VERSION)|" \
- -e "s|%FULL_NSPR_LIBS%|$(FULL_NSPR_LIBS)|" \
- -e "s|%FULL_NSPR_CFLAGS%|$(FULL_NSPR_CFLAGS)|" \
-+ -e "s|%FULL_NSS_LIBS%|$(FULL_NSS_LIBS)|" \
-+ -e "s|%FULL_NSS_CFLAGS%|$(FULL_NSS_CFLAGS)|" \
- -e "s|%NSPR_NAME%|$(NSPR_NAME)|" \
- -e "s|%NSPR_VERSION%|$(NSPR_VERSION)|" > $@
- chmod 644 $@
-
- install:: $(pkg_config_files)
- @echo pkg_config_file: $(pkg_config_files)
- $(SYSINSTALL) $(IFLAGS1) $^ $(DESTDIR)$(libdir)/pkgconfig
-
-Index: mozilla/xulrunner/installer/libxul-embedding-unstable.pc.in
-===================================================================
---- mozilla.orig/xulrunner/installer/libxul-embedding-unstable.pc.in
-+++ mozilla/xulrunner/installer/libxul-embedding-unstable.pc.in
-@@ -3,9 +3,9 @@
- includedir=%includedir%
- idldir=%idldir%
- includetype=unstable
-
- Name: libxul-embedding-unstable
- Description: Static library for version-independent embedding of the Mozilla runtime (unstable API)
- Version: %MOZILLA_VERSION%
- Libs: -L${sdkdir}/lib -lxpcomglue
--Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} -fshort-wchar
-+Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} -fshort-wchar %FULL_NSPR_CFLAGS%
-Index: mozilla/xulrunner/installer/libxul-embedding.pc.in
-===================================================================
---- mozilla.orig/xulrunner/installer/libxul-embedding.pc.in
-+++ mozilla/xulrunner/installer/libxul-embedding.pc.in
-@@ -7,9 +7,9 @@
- # Note: the default pkg-config cflags will only list include directories
- # that contain stable (frozen or safe for linking) header files. To include
- # nonfrozen headers, run pkg-config with --define-variable=includetype=unstable
-
- Name: libxul-embedding
- Description: Static library for version-independent embedding of the Mozilla runtime
- Version: %MOZILLA_VERSION%
- Libs: -L${sdkdir}/lib -lxpcomglue
--Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} -fshort-wchar
-+Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} -fshort-wchar %FULL_NSPR_CFLAGS%
-Index: mozilla/xulrunner/installer/mozilla-nss.pc.in
-===================================================================
---- mozilla.orig/xulrunner/installer/mozilla-nss.pc.in
-+++ mozilla/xulrunner/installer/mozilla-nss.pc.in
-@@ -1,10 +1,10 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
- includedir=%includedir%
-
- Name: NSS
- Description: Mozilla Network Security Services
--Version: %MOZILLA_VERSION%
-+Version: %NSS_VERSION%
- Requires: %NSPR_NAME% >= %NSPR_VERSION%
--Libs: -L${sdkdir}/lib -lnss3 -lnssutil3 -lsmime3 -lssl3 -lsoftokn3
--Cflags: -I${includedir}/stable
-+Libs: %FULL_NSS_LIBS%
-+Cflags: %FULL_NSS_CFLAGS%
diff --git a/abs/extra-testing/xulrunner/fix-mozilla-launcher.patch b/abs/extra-testing/xulrunner/fix-mozilla-launcher.patch
deleted file mode 100644
index de64e4c..0000000
--- a/abs/extra-testing/xulrunner/fix-mozilla-launcher.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- xulrunner/stub/nsXULStub.cpp 2008-07-17 21:43:11.000000000 +0200
-+++ xulrunner/stub/nsXULStub.cpp 2008-07-17 21:47:04.000000000 +0200
-@@ -208,8 +208,10 @@
- // 3) give up
-
- struct stat fileStat;
-+ char *testp;
-
-- if (!realpath(argv[0], iniPath) || stat(iniPath, &fileStat)) {
-+ testp = realpath(argv[0], iniPath);
-+ if (!(testp != NULL && stat(iniPath, &fileStat) == 0 && S_ISREG(fileStat.st_mode) && fileStat.st_mode & S_IXUSR) || (testp != NULL && stat(iniPath, &fileStat))) {
- const char *path = getenv("PATH");
- if (!path)
- return 1;
-@@ -222,7 +224,7 @@
- char *token = strtok(pathdup, ":");
- while (token) {
- sprintf(tmpPath, "%s/%s", token, argv[0]);
-- if (realpath(tmpPath, iniPath) && stat(iniPath, &fileStat) == 0) {
-+ if (realpath(tmpPath, iniPath) && stat(iniPath, &fileStat) == 0 && S_ISREG(fileStat.st_mode) && fileStat.st_mode & S_IXUSR) {
- found = PR_TRUE;
- break;
- }
diff --git a/abs/extra-testing/xulrunner/mozilla-pkgconfig.patch b/abs/extra-testing/xulrunner/mozilla-pkgconfig.patch
deleted file mode 100644
index 1ce40fd..0000000
--- a/abs/extra-testing/xulrunner/mozilla-pkgconfig.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-diff -ruN mozilla/xulrunner/installer/libxul-embedding.pc.in mozilla/xulrunner/installer/libxul-embedding.pc.in
---- mozilla/xulrunner/installer/libxul-embedding.pc.in 2008-07-16 20:27:31.000000000 +0200
-+++ mozilla/xulrunner/installer/libxul-embedding.pc.in 2008-07-16 21:43:47.000000000 +0200
-@@ -1,7 +1,7 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
- includedir=%includedir%
--idldir=%idldir%
-+idldir=%idldir%/stable
- includetype=stable
-
- # Note: the default pkg-config cflags will only list include directories
-diff -ruN mozilla/xulrunner/installer/libxul-embedding-unstable.pc.in mozilla/xulrunner/installer/libxul-embedding-unstable.pc.in
---- mozilla/xulrunner/installer/libxul-embedding-unstable.pc.in 2008-07-16 20:27:31.000000000 +0200
-+++ mozilla/xulrunner/installer/libxul-embedding-unstable.pc.in 2008-07-16 21:44:06.000000000 +0200
-@@ -1,7 +1,7 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
- includedir=%includedir%
--idldir=%idldir%
-+idldir=%idldir%/unstable
- includetype=unstable
-
- Name: libxul-embedding-unstable
-diff -ruN mozilla/xulrunner/installer/libxul.pc.in mozilla/xulrunner/installer/libxul.pc.in
---- mozilla/xulrunner/installer/libxul.pc.in 2007-08-03 16:46:28.000000000 +0200
-+++ mozilla/xulrunner/installer/libxul.pc.in 2008-07-16 21:44:33.000000000 +0200
-@@ -1,7 +1,8 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
-+libdir=%libdir%
- includedir=%includedir%
--idldir=%idldir%
-+idldir=%idldir%/stable
- includetype=stable
-
- # Note: the default pkg-config includes will only list include directories
-@@ -13,4 +14,4 @@
- Version: %MOZILLA_VERSION%
- Requires: %NSPR_NAME% >= %NSPR_VERSION%
- Libs: -L${sdkdir}/lib -lxpcomglue_s -lxul -lxpcom
--Cflags: -I${includedir}/${includetype} -fshort-wchar
-\ No newline at end of file
-+Cflags: -I${includedir}/${includetype} -fshort-wchar
-diff -ruN mozilla/xulrunner/installer/libxul-unstable.pc.in mozilla/xulrunner/installer/libxul-unstable.pc.in
---- mozilla/xulrunner/installer/libxul-unstable.pc.in 2008-01-05 07:50:34.000000000 +0100
-+++ mozilla/xulrunner/installer/libxul-unstable.pc.in 2008-07-16 21:45:11.000000000 +0200
-@@ -1,7 +1,8 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
-+libdir=%libdir%
- includedir=%includedir%
--idldir=%idldir%
-+idldir=%idldir%/unstable
- includetype=unstable
-
- Name: libxul
-diff -ruN mozilla/xulrunner/installer/Makefile.in mozilla/xulrunner/installer/Makefile.in
---- mozilla/xulrunner/installer/Makefile.in 2008-07-16 20:27:31.000000000 +0200
-+++ mozilla/xulrunner/installer/Makefile.in 2008-07-16 21:45:51.000000000 +0200
-@@ -125,6 +125,7 @@
- -e "s|%includedir%|$(includedir)|" \
- -e "s|%idldir%|$(idldir)|" \
- -e "s|%sdkdir%|$(sdkdir)|" \
-+ -e "s|%libdir%|$(installdir)|" \
- -e "s|%MOZ_APP_NAME%|$(MOZ_APP_NAME)|" \
- -e "s|%MOZILLA_VERSION%|$(MOZ_APP_VERSION)|" \
- -e "s|%FULL_NSPR_LIBS%|$(FULL_NSPR_LIBS)|" \
-diff -ruN mozilla/xulrunner/installer/mozilla-gtkmozembed-embedding.pc.in mozilla/xulrunner/installer/mozilla-gtkmozembed-embedding.pc.in
---- mozilla/xulrunner/installer/mozilla-gtkmozembed-embedding.pc.in 2008-01-10 10:17:49.000000000 +0100
-+++ mozilla/xulrunner/installer/mozilla-gtkmozembed-embedding.pc.in 2008-07-16 21:46:14.000000000 +0200
-@@ -1,5 +1,6 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
-+libdir=%libdir%
- includedir=%includedir%
-
- Name: mozilla-gtkembedmoz
-diff -ruN mozilla/xulrunner/installer/mozilla-gtkmozembed.pc.in mozilla/xulrunner/installer/mozilla-gtkmozembed.pc.in
---- mozilla/xulrunner/installer/mozilla-gtkmozembed.pc.in 2008-01-10 10:17:49.000000000 +0100
-+++ mozilla/xulrunner/installer/mozilla-gtkmozembed.pc.in 2008-07-16 21:46:28.000000000 +0200
-@@ -1,5 +1,6 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
-+libdir=%libdir%
- includedir=%includedir%
-
- Name: mozilla-gtkembedmoz
diff --git a/abs/extra-testing/xulrunner/mozilla-ps-pdf-simplify-operators.patch b/abs/extra-testing/xulrunner/mozilla-ps-pdf-simplify-operators.patch
deleted file mode 100644
index cab1341..0000000
--- a/abs/extra-testing/xulrunner/mozilla-ps-pdf-simplify-operators.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-https://bugzilla.mozilla.org/show_bug.cgi?id=435313
-
-Index: mozilla/gfx/thebes/public/gfxPDFSurface.h
-===================================================================
-RCS file: /cvsroot/mozilla/gfx/thebes/public/gfxPDFSurface.h,v
-retrieving revision 1.13
-diff -d -u -p -r1.13 gfxPDFSurface.h
---- mozilla/gfx/thebes/public/gfxPDFSurface.h 19 Mar 2008 20:51:42 -0000 1.13
-+++ mozilla/gfx/thebes/public/gfxPDFSurface.h 23 May 2008 00:50:31 -0000
-@@ -63,7 +63,11 @@ public:
- // this is in points!
- const gfxSize& GetSize() const { return mSize; }
-
-- virtual PRInt32 GetDefaultContextFlags() const { return gfxContext::FLAG_DISABLE_SNAPPING; }
-+ virtual PRInt32 GetDefaultContextFlags() const
-+ {
-+ return gfxContext::FLAG_SIMPLIFY_OPERATORS |
-+ gfxContext::FLAG_DISABLE_SNAPPING;
-+ }
-
- private:
- nsCOMPtr<nsIOutputStream> mStream;
-Index: mozilla/gfx/thebes/public/gfxPSSurface.h
-===================================================================
-RCS file: /cvsroot/mozilla/gfx/thebes/public/gfxPSSurface.h,v
-retrieving revision 1.13
-diff -d -u -p -r1.13 gfxPSSurface.h
---- mozilla/gfx/thebes/public/gfxPSSurface.h 19 Mar 2008 20:51:42 -0000 1.13
-+++ mozilla/gfx/thebes/public/gfxPSSurface.h 23 May 2008 00:50:31 -0000
-@@ -63,7 +63,11 @@ public:
- // this is in points!
- const gfxSize& GetSize() const { return mSize; }
-
-- virtual PRInt32 GetDefaultContextFlags() const { return gfxContext::FLAG_DISABLE_SNAPPING; }
-+ virtual PRInt32 GetDefaultContextFlags() const
-+ {
-+ return gfxContext::FLAG_SIMPLIFY_OPERATORS |
-+ gfxContext::FLAG_DISABLE_SNAPPING;
-+ }
-
- private:
- nsCOMPtr<nsIOutputStream> mStream;
diff --git a/abs/extra-testing/xulrunner/nsThreadUtils.patch b/abs/extra-testing/xulrunner/nsThreadUtils.patch
deleted file mode 100644
index 69609c0..0000000
--- a/abs/extra-testing/xulrunner/nsThreadUtils.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- xulrunner-1.9.0.4.orig/xpcom/glue/nsThreadUtils.cpp
-+++ xulrunner-1.9.0.4/xpcom/glue/nsThreadUtils.cpp
-@@ -187,24 +187,27 @@
- }
- #endif // XPCOM_GLUE_AVOID_NSPR
-
-+inline PRBool
-+hasPendingEvents(nsIThread *thread)
-+{
-+ PRBool val;
-+ return NS_SUCCEEDED(thread->HasPendingEvents(&val)) && val;
-+}
-+
- PRBool
- NS_HasPendingEvents(nsIThread *thread)
- {
--#ifdef MOZILLA_INTERNAL_API
- if (!thread) {
-+#ifndef MOZILLA_INTERNAL_API
-+ nsCOMPtr<nsIThread> current;
-+ NS_GetCurrentThread(getter_AddRefs(current));
-+ return hasPendingEvents(current);
-+#else
- thread = NS_GetCurrentThread();
- NS_ENSURE_TRUE(thread, PR_FALSE);
-- }
--#else
-- nsCOMPtr<nsIThread> current;
-- if (!thread) {
-- NS_GetCurrentThread(getter_AddRefs(current));
-- NS_ENSURE_TRUE(current, PR_FALSE);
-- thread = current.get();
-- }
- #endif
-- PRBool val;
-- return NS_SUCCEEDED(thread->HasPendingEvents(&val)) && val;
-+ }
-+ return hasPendingEvents(thread);
- }
-
- PRBool
-