summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/zip
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
commitc38715641e214272ad7dc6d495edd29940366e7f (patch)
tree9dcd507543e67458d98fa7462f62026041524047 /abs/extra-testing/zip
parent3d91b06198a56b6579cb0bd77de65f5908571b87 (diff)
downloadlinhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.zip
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.gz
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.bz2
packages that will be needed in the future.
This is the initial merge of packages from MythVantage that are not MythVantage specific.
Diffstat (limited to 'abs/extra-testing/zip')
-rw-r--r--abs/extra-testing/zip/ChangeLog5
-rw-r--r--abs/extra-testing/zip/PKGBUILD23
2 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra-testing/zip/ChangeLog b/abs/extra-testing/zip/ChangeLog
new file mode 100644
index 0000000..29ec4d1
--- /dev/null
+++ b/abs/extra-testing/zip/ChangeLog
@@ -0,0 +1,5 @@
+
+2008-07-27 Douglas Soares de Andrade <douglas@archlinux.org>
+
+ * Updating for i686: 3.0
+
diff --git a/abs/extra-testing/zip/PKGBUILD b/abs/extra-testing/zip/PKGBUILD
new file mode 100644
index 0000000..54eae73
--- /dev/null
+++ b/abs/extra-testing/zip/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 6705 2008-07-27 14:04:19Z douglas $
+# Maintainer: dorphell <dorphell@archlinux.org>
+
+pkgname=zip
+pkgver=3.0
+pkgrel=1
+pkgdesc="Creates PKZIP-compatible .zip files"
+arch=(i686 x86_64)
+url="http://www.info-zip.org/pub/infozip/Zip.html"
+depends=('glibc')
+makedepends=('unzip')
+source=(ftp://ftp.info-zip.org/pub/infozip/src/zip30.zip
+ ftp://ftp.info-zip.org/pub/infozip/src/zcrypt.zip)
+
+md5sums=('e88492c8abd68fa9cfba72bc08757dba'
+ '0c969ba1661183b041a142945ed2710e')
+
+build() {
+ cd $startdir/src/${pkgname}30
+ echo "A"| unzip ../zcrypt.zip
+ make -f unix/Makefile LOCAL_ZIP="$CFLAGS" prefix=/usr generic_gcc || return 1
+ make -f unix/Makefile INSTALL=`which install` prefix=$startdir/pkg/usr install
+}