summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-10-19 19:21:35 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-10-19 19:21:35 (GMT)
commit59bb81e4db2bda0d63e2fb7f895792dba6c20073 (patch)
tree09ed11c77b968807e8c88755fb82236a0d1b7447 /abs/extra-testing
parent0d75027f7b76a40a8393ea12c9349051d82863d1 (diff)
parent3b0242f860b4efa19fd91a6bd1e3127fd4b8aa9f (diff)
downloadlinhes_pkgbuild-59bb81e4db2bda0d63e2fb7f895792dba6c20073.zip
linhes_pkgbuild-59bb81e4db2bda0d63e2fb7f895792dba6c20073.tar.gz
linhes_pkgbuild-59bb81e4db2bda0d63e2fb7f895792dba6c20073.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing')
-rw-r--r--abs/extra-testing/community/firefox/PKGBUILD5
-rw-r--r--abs/extra-testing/ddclient/ChangeLog22
-rw-r--r--abs/extra-testing/ddclient/PKGBUILD30
-rw-r--r--abs/extra-testing/ddclient/ddclient-foreground.patch47
-rw-r--r--abs/extra-testing/ddclient/ddclient.conf.d2
-rw-r--r--abs/extra-testing/ddclient/ddclient.conf.dynamic.dyndns.sample162
-rw-r--r--abs/extra-testing/ddclient/ddclient.install41
-rw-r--r--abs/extra-testing/ddclient/ddclient.rc37
-rw-r--r--abs/extra-testing/deb2targz/PKGBUILD20
-rw-r--r--abs/extra-testing/huludesktop/PKGBUILD21
-rw-r--r--abs/extra-testing/huludesktop/huludesktop25
-rw-r--r--abs/extra-testing/huludesktop/huludesktop.install26
-rw-r--r--abs/extra-testing/mupen64plus-svn/PKGBUILD71
-rw-r--r--abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch22
-rw-r--r--abs/extra-testing/mupen64plus-svn/install.patch13
15 files changed, 424 insertions, 120 deletions
diff --git a/abs/extra-testing/community/firefox/PKGBUILD b/abs/extra-testing/community/firefox/PKGBUILD
index 191c913..17a70b3 100644
--- a/abs/extra-testing/community/firefox/PKGBUILD
+++ b/abs/extra-testing/community/firefox/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=firefox
pkgver=3.5.1
-pkgrel=3
+pkgrel=4
_xulver=1.9.1.1
pkgdesc="Standalone web browser from mozilla.org"
arch=(i686 x86_64)
license=('MPL' 'GPL' 'LGPL')
-depends=("xulrunner>=${_xulver}" 'desktop-file-utils' "nspr>=4.8")
+depends=("xulrunner>=${_xulver}" 'desktop-file-utils' "nspr>=4.8" gconf)
makedepends=('zip' 'pkgconfig' 'diffutils' 'libgnomeui>=2.24.1' 'python')
replaces=('firefox3')
install=firefox.install
@@ -70,6 +70,7 @@ build() {
mv ${pkgdir}/usr/bin/firefox ${pkgdir}/usr/bin/firefox.bin
echo "#!/bin/bash
+/usr/lib/GConf/gconfd-2 &
export LD_PRELOAD=/usr/lib/libGL.so.1
/usr/bin/firefox.bin" > ${pkgdir}/usr/bin/firefox
chmod 755 ${pkgdir}/usr/bin/firefox
diff --git a/abs/extra-testing/ddclient/ChangeLog b/abs/extra-testing/ddclient/ChangeLog
deleted file mode 100644
index 4520b69..0000000
--- a/abs/extra-testing/ddclient/ChangeLog
+++ /dev/null
@@ -1,22 +0,0 @@
-2008-08-07 Abhishek Dasgupta <abhidg@gmail.com>
-
- * ddclient 3.7.3-2
- * added /etc/conf.d/ddclient for modifying
- daemon poll frequency. This overrides the
- setting specified in /etc/ddclient/ddclient.conf
- when ddclient is called as an rc script.
-
-2007-08-08 Alessio 'mOLOk' Bolognino <themolok@gmail.com>
-
- * ddclient-3.7.3-1
- * version bump
- * GPL -> GPL2
- * shortened pkgdesc
-
-2007-07-02 tardo <tardo@nagi-fanboi.net>
-
- * Built for x86_64
-
-2007-06-29 Georg Grabler (STiAT) <ggrabler@gmail.com>
-
- * Version Bump to 3.7.2
diff --git a/abs/extra-testing/ddclient/PKGBUILD b/abs/extra-testing/ddclient/PKGBUILD
index 121d2c5..f283cb9 100644
--- a/abs/extra-testing/ddclient/PKGBUILD
+++ b/abs/extra-testing/ddclient/PKGBUILD
@@ -3,33 +3,31 @@
# Contributor: David Rosenstrauch <darose@darose.net>
pkgname=ddclient
-pkgver=3.7.3
-pkgrel=2
+pkgver=3.8.0
+pkgrel=1
pkgdesc="Update dynamic DNS entries for accounts on many dynamic DNS services."
arch=('i686' 'x86_64')
url="http://ddclient.sourceforge.net/"
license=('GPL2')
depends=('perl' 'perl-io-socket-ssl')
-backup=('etc/ddclient/ddclient.conf' 'etc/conf.d/ddclient')
-install=ddclient.install
-source=(http://downloads.sourceforge.net/sourceforge/ddclient/ddclient-$pkgver.tar.bz2 ddclient.rc ddclient.conf.d)
+backup=('etc/ddclient.conf')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
+ ddclient.conf.dynamic.dyndns.sample
+ ddclient-foreground.patch)
build() {
- cd ${srcdir}/ddclient-${pkgver}
+ cd ${srcdir}/$pkgname-${pkgver}
+ patch < ${srcdir}/ddclient-foreground.patch
# core files
install -D -m755 ddclient ${pkgdir}/usr/sbin/ddclient
- install -D -m755 ${srcdir}/ddclient.rc ${pkgdir}/etc/rc.d/ddclient
- install -D -m600 sample-etc_ddclient.conf ${pkgdir}/etc/ddclient/ddclient.conf
- install -D -m644 ${srcdir}/ddclient.conf.d ${pkgdir}/etc/conf.d/ddclient
+ install -D -m600 sample-etc_ddclient.conf ${pkgdir}/etc/ddclient/ddclient.conf.sample
+ install -D -m600 ${srcdir}/ddclient.conf.dynamic.dyndns.sample ${pkgdir}/etc/ddclient/
install -d ${pkgdir}/var/cache/ddclient
# additional instructions, sample configs
- install -D -m644 README ${pkgdir}/etc/ddclient/samples/README
- install -D -m644 sample-etc_cron.d_ddclient ${pkgdir}/etc/ddclient/samples/sample-etc_cron.d_ddclient
- install -D -m644 sample-etc_dhcpc_dhcpcd-eth0.exe ${pkgdir}/etc/ddclient/samples/sample-etc_dhcpc_dhcpcd-eth0.exe
- install -D -m644 sample-etc_ppp_ip-up.local ${pkgdir}/etc/ddclient/samples/sample-etc_ppp_ip-up.local
+ install -D -m644 README ${pkgdir}/etc/ddclient/README
}
-md5sums=('f6a55bc68cf73ffe7e80d2fa5cd44f85'
- '7035bf8132f3517a59167f61ee5e8b90'
- 'b8f39c82827776da948b76ef83544d33')
+md5sums=('6cac7a5eb1da781bfd4d98cef0b21f8e'
+ '4194825b9b4a7fcc1c57c2f5a4f6162b'
+ 'd8ffc95f98f9afcb4a06a1e192220e35')
diff --git a/abs/extra-testing/ddclient/ddclient-foreground.patch b/abs/extra-testing/ddclient/ddclient-foreground.patch
new file mode 100644
index 0000000..a814ede
--- /dev/null
+++ b/abs/extra-testing/ddclient/ddclient-foreground.patch
@@ -0,0 +1,47 @@
+--- ../ddclient-orig/ddclient 2009-10-19 22:45:15.000000000 +1030
++++ ddclient 2009-10-19 22:50:11.000000000 +1030
+@@ -307,6 +307,7 @@
+ my %variables = (
+ 'global-defaults' => {
+ 'daemon' => setv(T_DELAY, 0, 0, 1, 0, interval('60s')),
++ 'foreground' => setv(T_BOOL, 0, 0, 1, 0, undef),
+ 'file' => setv(T_FILE, 0, 0, 1, "$etc$program.conf", undef),
+ 'cache' => setv(T_FILE, 0, 0, 1, "$cachedir$program.cache", undef),
+ 'pid' => setv(T_FILE, 0, 0, 1, "", undef),
+@@ -535,6 +536,7 @@
+ "usage: ${program} [options]",
+ "options are:",
+ [ "daemon", "=s", "-daemon delay : run as a daemon, specify delay as an interval." ],
++ [ "foreground", "!", "-foreground : do not fork" ],
+ [ "proxy", "=s", "-proxy host : use 'host' as the HTTP proxy" ],
+ [ "server", "=s", "-server host : update DNS information on 'host'" ],
+ [ "protocol", "=s", "-protocol type : update protocol used" ],
+@@ -623,7 +625,10 @@
+ $SIG{'HUP'} = sub { $caught_hup = 1; };
+ $SIG{'TERM'} = sub { $caught_term = 1; };
+ $SIG{'KILL'} = sub { $caught_kill = 1; };
+-if (opt('daemon') && !opt('force')) {
++# don't fork() if foreground or force is on
++if (opt('foreground') || opt('force')) {
++ ;
++} elsif (opt('daemon')) {
+ $SIG{'CHLD'} = 'IGNORE';
+ my $pid = fork;
+ if ($pid < 0) {
+@@ -633,12 +638,15 @@
+ exit 0;
+ }
+ $SIG{'CHLD'} = 'DEFAULT';
+- $opt{'syslog'} = 1;
+ open(STDOUT, ">/dev/null");
+ open(STDERR, ">/dev/null");
+ open(STDIN, "</dev/null");
++}
+
++# write out the pid file if we're daemon'ized
++if(opt('daemon')) {
+ write_pid();
++ $opt{'syslog'} = 1;
+ }
+
+ umask 077;
diff --git a/abs/extra-testing/ddclient/ddclient.conf.d b/abs/extra-testing/ddclient/ddclient.conf.d
deleted file mode 100644
index 8b754a3..0000000
--- a/abs/extra-testing/ddclient/ddclient.conf.d
+++ /dev/null
@@ -1,2 +0,0 @@
-# Parameters passed to ddclient
-EXTRA_ARGS="-daemon 300"
diff --git a/abs/extra-testing/ddclient/ddclient.conf.dynamic.dyndns.sample b/abs/extra-testing/ddclient/ddclient.conf.dynamic.dyndns.sample
new file mode 100644
index 0000000..a492c8b
--- /dev/null
+++ b/abs/extra-testing/ddclient/ddclient.conf.dynamic.dyndns.sample
@@ -0,0 +1,162 @@
+######################################################################
+##
+## $Id: sample-etc_ddclient.conf 102 2008-11-01 11:23:03Z wimpunk $
+##
+## Define default global variables with lines like:
+## var=value [, var=value]*
+## These values will be used for each following host unless overridden
+## with a local variable definition.
+##
+## Define local variables for one or more hosts with:
+## var=value [, var=value]* host.and.domain[,host2.and.domain...]
+##
+## Lines can be continued on the following line by ending the line
+## with a \
+##
+##
+## Warning: not all supported routers or dynamic DNS services
+## are mentioned here.
+##
+######################################################################
+daemon=300 # check every 300 seconds
+syslog=yes # log update msgs to syslog
+mail=root # mail all msgs to root
+mail-failure=root # mail failed update msgs to root
+pid=/var/run/ddclient.pid # record PID in file.
+ssl=yes # use ssl-support. Works with
+ # ssl-library
+# postscript=script # run script after updating. The
+ # new IP is added as argument.
+#
+#use=watchguard-soho, fw=192.168.111.1:80 # via Watchguard's SOHO FW
+#use=netopia-r910, fw=192.168.111.1:80 # via Netopia R910 FW
+#use=smc-barricade, fw=192.168.123.254:80 # via SMC's Barricade FW
+#use=netgear-rt3xx, fw=192.168.0.1:80 # via Netgear's internet FW
+#use=linksys, fw=192.168.1.1:80 # via Linksys's internet FW
+#use=maxgate-ugate3x00, fw=192.168.0.1:80 # via MaxGate's UGATE-3x00 FW
+#use=elsa-lancom-dsl10, fw=10.0.0.254:80 # via ELSA LanCom DSL/10 DSL Router
+#use=elsa-lancom-dsl10-ch01, fw=10.0.0.254:80 # via ELSA LanCom DSL/10 DSL Router
+#use=elsa-lancom-dsl10-ch02, fw=10.0.0.254:80 # via ELSA LanCom DSL/10 DSL Router
+#use=alcatel-stp, fw=10.0.0.138:80 # via Alcatel Speed Touch Pro
+#use=xsense-aero, fw=192.168.1.1:80 # via Xsense Aero Router
+#use=allnet-1298, fw=192.168.1.1:80 # via AllNet 1298 DSL Router
+#use=3com-oc-remote812, fw=192.168.0.254:80 # via 3com OfficeConnect Remote 812
+#use=e-tech, fw=192.168.1.1:80 # via E-tech Router
+#use=cayman-3220h, fw=192.168.0.1:1080 # via Cayman 3220-H DSL Router
+#
+#fw-login=admin, fw-password=XXXXXX # FW login and password
+#
+## To obtain an IP address from FW status page (using fw-login, fw-password)
+#use=fw, fw=192.168.1.254/status.htm, fw-skip='IP Address' # found after IP Address
+#
+## To obtain an IP address from Web status page (using the proxy if defined)
+#use=web, web=checkip.dyndns.org/, web-skip='IP Address' # found after IP Address
+#
+#use=ip, ip=127.0.0.1 # via static IP's
+#use=if, if=eth0 # via interfaces
+use=web # via web
+#
+#protocol=dyndns2 # default protocol
+#proxy=fasthttp.sympatico.ca:80 # default proxy
+#server=members.dyndns.org # default server
+#server=members.dyndns.org:8245 # default server (bypassing proxies)
+
+login=your-dynamic-dyndns-login # default login
+password=your-dynamic-dyndns-password # default password
+#mx=mx.for.your.host # default MX
+#backupmx=yes|no # host is primary MX?
+#wildcard=yes|no # add wildcard CNAME?
+
+##
+## dyndns.org dynamic addresses
+##
+## (supports variables: wildcard,mx,backupmx)
+##
+server=members.dyndns.org, \
+protocol=dyndns2 \
+your-dynamic-dyndns-host
+
+##
+## dyndns.org static addresses
+##
+## (supports variables: wildcard,mx,backupmx)
+##
+# static=yes, \
+# server=members.dyndns.org, \
+# protocol=dyndns2 \
+# your-static-host.dyndns.org
+
+##
+##
+## dyndns.org custom addresses
+##
+## (supports variables: wildcard,mx,backupmx)
+##
+# custom=yes, \
+# server=members.dyndns.org, \
+# protocol=dyndns2 \
+# your-domain.top-level,your-other-domain.top-level
+
+##
+## ZoneEdit (zoneedit.com)
+##
+# server=dynamic.zoneedit.com, \
+# protocol=zoneedit1, \
+# login=your-zoneedit-login, \
+# password=your-zoneedit-password \
+# your.any.domain,your-2nd.any.dom
+
+##
+## EasyDNS (easydns.com)
+##
+# server=members.easydns.com, \
+# protocol=easydns, \
+# login=your-easydns-login, \
+# password=your-easydns-password \
+# your.any.domain,your-2nd.any.domain
+
+##
+## Hammernode (hn.org) dynamic addresses
+##
+# server=dup.hn.org, \
+# protocol=hammernode1, \
+# login=your-hn-login, \
+# password=your-hn-password \
+# your-hn-host.hn.org,your-2nd-hn-host.hn.org
+
+##
+## dslreports.com dynamic-host monitoring
+##
+# server=members.dslreports.com \
+# protocol=dslreports1, \
+# login=dslreports-login, \
+# password=dslreports-password \
+# dslreports-unique-id
+
+##
+## OrgDNS.org account-configuration
+##
+# use=web, web=members.orgdns.org/nic/ip
+# server=www.orgdns.org \
+# protocol=dyndns2 \
+# login=yourLoginName \
+# password=yourPassword \
+# yourSubdomain.orgdns.org
+
+##
+## dnspark.com
+## (supports variables: mx, mxpri)
+##
+# use=web, web=ipdetect.dnspark.com, web-skip='Current Address:'
+# protocol=dnspark, \
+# server=www.dnspark.com, \
+# your-host.dnspark.com
+
+##
+## NameCheap (namecheap.com)
+##
+# protocol=namecheap, \
+# server=dynamicdns.park-your-domain.com, \
+# login=my-namecheap.com-login, \
+# password=my-namecheap.com-password \
+# myhost.namecheap.com
diff --git a/abs/extra-testing/ddclient/ddclient.install b/abs/extra-testing/ddclient/ddclient.install
deleted file mode 100644
index d6edc0e..0000000
--- a/abs/extra-testing/ddclient/ddclient.install
+++ /dev/null
@@ -1,41 +0,0 @@
-# arg 1: the new package version
-post_install() {
-cat << EOM
-
-If you want to use ddclient with dhcpcd, cron or pppd,
-see /etc/ddclient/samples for further instructions.
-
-If you have ddclient in the DAEMONS array of /etc/rc.conf:
-- Change /etc/conf.d/ddclient according to your needs.
-- This setting OVERRIDES any setting in
- /etc/ddclient/ddclient.conf
-
-EOM
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
-
-if [ -f /etc/ddclient/ddclient.cache ]; then
- echo -n "Moving ddclient.cache from /etc/ddclient/ to /var/cache/ddclient/."
- mv /etc/ddclient/ddclient.cache /var/cache/ddclient/
- echo " (done)"
-fi
-
-if [ "$(vercmp $2 3.7.3-2)" -lt 0 ]; then
-cat << EOM
-
-If you have ddclient in the DAEMONS array of /etc/rc.conf:
-- Change /etc/conf.d/ddclient according to your needs.
-- This setting OVERRIDES any setting in
- /etc/ddclient/ddclient.conf
-
-EOM
-fi
-
-}
-
-op=$1
-shift
-$op $*
diff --git a/abs/extra-testing/ddclient/ddclient.rc b/abs/extra-testing/ddclient/ddclient.rc
deleted file mode 100644
index a9093f7..0000000
--- a/abs/extra-testing/ddclient/ddclient.rc
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/bash
-
-[ -f /etc/conf.d/ddclient ] && . /etc/conf.d/ddclient
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=`pidof -o %PPID /usr/sbin/ddclient`
-case "$1" in
- start)
- stat_busy "Starting ddclient"
- [ -z "$PID" ] && /usr/sbin/ddclient ${EXTRA_ARGS}
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon ddclient
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping ddclient"
- [ -n "$PID" ] && kill -15 $PID >/dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon ddclient
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
diff --git a/abs/extra-testing/deb2targz/PKGBUILD b/abs/extra-testing/deb2targz/PKGBUILD
new file mode 100644
index 0000000..adf074d
--- /dev/null
+++ b/abs/extra-testing/deb2targz/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Douglas Soares de Andrade <dsandrade@gmail.org>
+# Contributor: Jason Erik Jackson <jacksonje@gmail.org>
+
+pkgname=deb2targz
+pkgver=1
+pkgrel=2
+pkgdesc="Converts .deb archives to tar.gz"
+arch=('i686' 'x86_64')
+url="http://www.miketaylor.org.uk/tech/deb/"
+depends=("perl")
+source=("http://www.miketaylor.org.uk/tech/deb/$pkgname")
+
+md5sums=('5b944785778d023a43e33af53bea2056')
+
+build() {
+ mkdir -p $startdir/pkg/usr/bin
+ install -m755 $startdir/src/$pkgname $startdir/pkg/usr/bin
+}
+
+
diff --git a/abs/extra-testing/huludesktop/PKGBUILD b/abs/extra-testing/huludesktop/PKGBUILD
new file mode 100644
index 0000000..b215d19
--- /dev/null
+++ b/abs/extra-testing/huludesktop/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=huludesktop
+pkgver=0.1
+pkgrel=5
+pkgdesc="Hulu Desktop for Linux"
+arch=(i686)
+url="http://www.hulu.com/labs/hulu-desktop-linux"
+license=('unknown')
+makedepends=('deb2targz')
+depends=('glib2' 'gtk2' 'lirc' 'flashplugin')
+install=huludesktop.install
+options=('')
+source=('http://download.hulu.com/huludesktop_i386.deb' 'huludesktop')
+md5sums=('ee339181b7fb206e2ca2795d46213529')
+
+build() {
+ cd $startdir/src
+ deb2targz huludesktop_i386.deb
+ tar -xzvf huludesktop_i386.tar.gz -C $pkgdir
+ mkdir -p $pkgdir/home/mythtv
+ cp huludesktop $pkgdir/home/mythtv/.huludesktop
+}
diff --git a/abs/extra-testing/huludesktop/huludesktop b/abs/extra-testing/huludesktop/huludesktop
new file mode 100644
index 0000000..c3ae870
--- /dev/null
+++ b/abs/extra-testing/huludesktop/huludesktop
@@ -0,0 +1,25 @@
+[display]
+fullscreen = TRUE
+width = 1024
+height = 576
+pos_x = 201
+pos_y = 179
+
+[remote]
+lirc_device = /dev/lircd
+lirc_remote_identifier = mceusb
+lirc_release_suffix = _UP
+lirc_repeat_threshold = 10
+button_name_up = Up
+button_name_down = Down
+button_name_left = Left
+button_name_right = Right
+button_name_select = OK
+button_name_menu = Home
+
+[flash]
+flash_location = /usr/lib/mozilla/plugins/libflashplayer.so
+
+[version]
+latest = (null)
+eula_version = 0
diff --git a/abs/extra-testing/huludesktop/huludesktop.install b/abs/extra-testing/huludesktop/huludesktop.install
new file mode 100644
index 0000000..271c5a1
--- /dev/null
+++ b/abs/extra-testing/huludesktop/huludesktop.install
@@ -0,0 +1,26 @@
+# arg 1: the new package version
+post_install() {
+ mv /usr/share/mythtv/is.xml /tmp
+ grep -v -e /mythmenu /tmp/is.xml > /tmp/is.xml.tmp
+ echo "<!--#Hulu-->" >> /tmp/is.xml.tmp
+ echo " <button>" >> /tmp/is.xml.tmp
+ echo " <type>STREAM</type>" >> /tmp/is.xml.tmp
+ echo " <text>Hulu Desktop</text>" >> /tmp/is.xml.tmp
+ echo " <action>EXEC huludesktop</action>" >> /tmp/is.xml.tmp
+ echo " </button>" >> /tmp/is.xml.tmp
+ echo "<!--#Hulu-->" >> /tmp/is.xml.tmp
+ echo "" >> /tmp/is.xml.tmp
+ echo "</mythmenu>" >> /tmp/is.xml.tmp
+ mv /tmp/is.xml.tmp /usr/share/mythtv/is.xml
+}
+# arg 1: the new package version
+# arg 2: the old package version
+post_remove() {
+ rm -fr /usr/share/mythtv/appletrailer.xml
+ mv /usr/share/mythtv/is.xml /tmp/is.xml.tmp
+ sed -e '/\#Hulu/,/\#Hulu/d' < /tmp/is.xml.tmp > /usr/share/mythtv/is.xml
+}
+
+op=$1
+shift
+$op $*
diff --git a/abs/extra-testing/mupen64plus-svn/PKGBUILD b/abs/extra-testing/mupen64plus-svn/PKGBUILD
new file mode 100644
index 0000000..5df794d
--- /dev/null
+++ b/abs/extra-testing/mupen64plus-svn/PKGBUILD
@@ -0,0 +1,71 @@
+#!!! Due to a limitation in pacman's SVN package handling,
+# this package requires out-of-the-ordinary building. pacman checks
+# the SVN repo for new revisions before scanning the PKGBUILD.
+#!!! So, when you run makepkg, if it asks you for a password for 'mupen64',
+# give it 'Dyson5632-kart' without the quotes. If it asks for a password
+# for _your_ username, hit Enter to make it ask for a new username, tell it
+# 'mupen64' without the quotes, and then give it the password above. When
+# it asks you to save the password unencrypted, you can say yes, because
+# it's just a read-only access login :P Once you do that, you shouldn't
+# need to do the above anymore.
+
+# Maintainer: Devin Cofer <ranguvar@archlinux.us>
+# Contributor: Rudy Matela <rudy.matela@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Zephyr
+
+pkgname=mupen64plus-svn
+pkgver=1416
+pkgrel=1
+pkgdesc="Nintendo64 emulator, SVN version"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/mupen64plus/"
+license=('GPL2')
+
+makedepends=('subversion' 'pkgconfig' 'libsamplerate' 'yasm' 'mesa')
+depends=('gtk2' 'sdl_ttf')
+optdepends=('libsamplerate: Higher quality audio')
+conflicts=('mupen64plus')
+provides=('mupen64plus')
+source=('install.patch'
+ 'fix-gcc4.4-const-char.patch')
+md5sums=('f6a3bc6e59d4f2af9db1b3fce257eb43'
+ '7bb0182949bf043847ad7ff66097e66f')
+
+_svnuser=mupen64
+_svnpass=Dyson5632-kart
+_svntrunk=svn://$_svnuser:$_svnpass@fascination.homelinux.net:7684/mupen64plus/trunk
+_svnmod=mupen64plus
+
+build() {
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod &&\
+ svn up --config-dir . -r $pkgver \
+ --non-interactive --username $_svnuser --password $_svnpass)
+ else
+ svn co $_svntrunk --config-dir . -r $pkgver $_svnmod \
+ --non-interactive --username $_svnuser --password $_svnpass
+ fi
+ msg "SVN checkout done or server timeout"
+
+ cp -r $_svnmod $_svnmod-build
+ patch -d $_svnmod-build < install.patch || return 1
+# patch -p0 -d $_svnmod-build < fix-gcc4.4-const-char.patch || return 1
+ cd $_svnmod-build
+
+ make PREFIX="/usr" LIRC=1 all || return 1
+ make PREFIX="$pkgdir/usr" install || return 1
+
+ ##### Qt 4 GUI build #####
+ #==> Currently broken
+ #make PREFIX="/usr" GUI=QT4 all || return 1
+ #install -m755 mupen64plus "$pkgdir/usr/bin/mupen64plus-qt"
+ #
+ #cd "$pkgdir/usr/share/applications"
+ #cp mupen64plus.desktop mupen64plus-qt.desktop
+ #sed -i "s#Name=Mupen64Plus#Name=Mupen64Plus (Qt)#" mupen64plus-qt.desktop || return 1
+ #sed -i "s#Exec=mupen64plus#Exec=mupen64plus-qt#" mupen64plus-qt.desktop || return 1
+ ##### End Qt 4 GUI build #####
+
+ rm -r "$srcdir/$_svnmod-build"
+}
diff --git a/abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch b/abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch
new file mode 100644
index 0000000..fd1495d
--- /dev/null
+++ b/abs/extra-testing/mupen64plus-svn/fix-gcc4.4-const-char.patch
@@ -0,0 +1,22 @@
+--- glide64/Combine.old.cpp 2009-06-19 17:59:20.191723065 -0400
++++ glide64/Combine.cpp 2009-06-19 18:43:46.955453868 -0400
+@@ -11873,7 +11873,7 @@
+ LOG ("InitCombine() ");
+ memset(&cmb, 0, sizeof(cmb));
+ const char *extensions = grGetString (GR_EXTENSION);
+- if (char * extstr = strstr(extensions, "COMBINE")) {
++ if (const char * extstr = strstr(extensions, "COMBINE")) {
+ if (!strncmp(extstr, "COMBINE", 7)) {
+ LOG ("extensions ");
+ cmb.grColorCombineExt = (GRCOLORCOMBINEEXT) grGetProcAddress("grColorCombineExt");
+--- glide64/Main.old.cpp 2009-06-19 18:47:04.238930057 -0400
++++ glide64/Main.cpp 2009-06-19 18:47:18.018772876 -0400
+@@ -784,7 +784,7 @@
+ printf("bebefore2\n");
+ if (settings.fb_hires)
+ {
+- if (char * extstr = strstr(extensions, "TEXTUREBUFFER"))
++ if (const char * extstr = strstr(extensions, "TEXTUREBUFFER"))
+ {
+ if (!strncmp(extstr, "TEXTUREBUFFER", 13))
+ {
diff --git a/abs/extra-testing/mupen64plus-svn/install.patch b/abs/extra-testing/mupen64plus-svn/install.patch
new file mode 100644
index 0000000..5e41460
--- /dev/null
+++ b/abs/extra-testing/mupen64plus-svn/install.patch
@@ -0,0 +1,13 @@
+Index: install.sh
+===================================================================
+--- install.sh (revision 1295)
++++ install.sh (working copy)
+@@ -90,7 +90,7 @@
+ if [ -f mupen64plus.desktop ]
+ then
+ $INSTALL -d -v "${APPLICATIONSDIR}"
+- $INSTALL -m 0644 mupen64plus.desktop "${APPLICATIONSDIR}"
++ $INSTALL -m 0644 mupen64plus.desktop "${APPLICATIONSDIR}/mupen64plus.desktop"
+ fi
+ if [ "x$(ls plugins/)" != "x" ]
+ then