summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-19 15:22:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-19 15:22:40 (GMT)
commiteaa1e24dfe16f3f5a3d12b194f977e971c8f4b4b (patch)
tree1039b920717da374ee67975622724f17f6fe89e1 /abs/extra-testing
parente7d7822ab75eeb5b35fd7ee6d9a1cfc4e730272e (diff)
parent6f90626a0bf289be8f0497fd6b135c7ef831e0fd (diff)
downloadlinhes_pkgbuild-eaa1e24dfe16f3f5a3d12b194f977e971c8f4b4b.zip
linhes_pkgbuild-eaa1e24dfe16f3f5a3d12b194f977e971c8f4b4b.tar.gz
linhes_pkgbuild-eaa1e24dfe16f3f5a3d12b194f977e971c8f4b4b.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/extra-testing')
-rw-r--r--abs/extra-testing/webmin/PKGBUILD19
-rw-r--r--abs/extra-testing/webmin/run11
2 files changed, 25 insertions, 5 deletions
diff --git a/abs/extra-testing/webmin/PKGBUILD b/abs/extra-testing/webmin/PKGBUILD
index f7fc020..1ce083e 100644
--- a/abs/extra-testing/webmin/PKGBUILD
+++ b/abs/extra-testing/webmin/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=webmin
pkgver=1.441
-pkgrel=1
+pkgrel=2
pkgdesc="a web-based interface for system administration"
arch=(i686 x86_64)
license=('custom:webmin')
@@ -86,7 +86,8 @@ install=webmin.install
source=(http://downloads.sourceforge.net/sourceforge/webadmin/$pkgname-$pkgver.tar.gz
ftp://ftp.archlinux.org/other/webmin/webmin-config.tar.bz2
ftp://ftp.archlinux.org/other/webmin/webmin-pacman.tar.bz2
- webmin.rc)
+ webmin.rc
+ run)
build() {
# NOTE: USE --asroot build option to avoid fakeroot error!
@@ -192,8 +193,11 @@ build() {
sed -i 's:^pidfile=.*$:pidfile=/var/run/webmin.pid:' $startdir/pkg/etc/webmin/miniserv.conf
find $startdir/pkg/etc/webmin -type f -exec sed -i "s:$startdir/pkg::g" {} \;
- # make it only accessible by localhost
- echo 'allow=127.0.0.1' >> $startdir/pkg/etc/webmin/miniserv.conf
+ # make it only accessible by localhost and private networks
+ echo 'allow=127.0.0.1 192.168. 172.16. 10.' >> $startdir/pkg/etc/webmin/miniserv.conf
+
+ #Let not fork this bad boy. We need to control it w/ runit.
+ echo 'nofork=1' >> $startdir/pkg/etc/webmin/miniserv.conf
# install pacman menu
cd $startdir/src/webmin-pacman/config
@@ -206,8 +210,13 @@ build() {
rm -r $startdir/pkg/tmp
# install license
install -m 644 -D $startdir/src/$pkgname-$pkgver/LICENCE $startdir/pkg/usr/share/licenses/webmin/LICENCE
+
+ #runit
+ mkdir -p $startdir/pkg/etc/sv/webmin/supervise
+ install -D -m 755 $startdir/src/run $startdir/pkg/etc/sv/webmin
}
md5sums=('b841af1b1a9f78795814ce8211e6ad81'
'da6bea412a5be8cf82a813078fec5847'
'4cf1139093ea59044be42a4f173fb8aa'
- '0673e51af0e81418b4a6c1e205f7e5cd')
+ '0673e51af0e81418b4a6c1e205f7e5cd'
+ 'bc578b249e2090deb84119a626c53c48')
diff --git a/abs/extra-testing/webmin/run b/abs/extra-testing/webmin/run
new file mode 100644
index 0000000..659c6cd
--- /dev/null
+++ b/abs/extra-testing/webmin/run
@@ -0,0 +1,11 @@
+#!/bin/sh
+echo Starting Webmin server in /opt/webmin
+trap '' 1
+LANG=
+export LANG
+#PERLIO=:raw
+unset PERLIO
+export PERLIO
+PERLLIB=/opt/webmin
+export PERLLIB
+exec '/opt/webmin/miniserv.pl' /etc/webmin/miniserv.conf