summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-03-25 17:43:04 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-03-25 17:43:04 (GMT)
commit43e339db3b03991725137cc1538215c26d5c9b64 (patch)
tree969f9fd61b9018b58e6516e02ee02b75dfb62d53 /abs/extra-testing
parent10b4773ed5a39f59be3b9d9de0ddd7a53381df99 (diff)
parent0818619a55d0aa584ee30dfef1c99c4ffed8dcdb (diff)
downloadlinhes_pkgbuild-43e339db3b03991725137cc1538215c26d5c9b64.zip
linhes_pkgbuild-43e339db3b03991725137cc1538215c26d5c9b64.tar.gz
linhes_pkgbuild-43e339db3b03991725137cc1538215c26d5c9b64.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing')
-rw-r--r--abs/extra-testing/python-pyserial/PKGBUILD20
-rw-r--r--abs/extra-testing/recstat/PKGBUILD19
-rw-r--r--abs/extra-testing/recstat/recstat56
-rw-r--r--abs/extra-testing/recstat/recstat.install13
-rw-r--r--abs/extra-testing/recstat/recstat.py38
-rwxr-xr-xabs/extra-testing/recstat/run7
-rw-r--r--abs/extra-testing/rrd_stats/PKGBUILD3
-rw-r--r--abs/extra-testing/rrd_stats/rrd_stats.tgzbin7454 -> 8444 bytes
8 files changed, 155 insertions, 1 deletions
diff --git a/abs/extra-testing/python-pyserial/PKGBUILD b/abs/extra-testing/python-pyserial/PKGBUILD
new file mode 100644
index 0000000..d90ee2d
--- /dev/null
+++ b/abs/extra-testing/python-pyserial/PKGBUILD
@@ -0,0 +1,20 @@
+# $Id: PKGBUILD 82 2009-07-17 19:56:55Z aaron $
+# Maintainer: Douglas Soares de Andrade <dsandrade@gmail.com>
+# Contributor: Douglas Soares de Andrade <dsandrade@gmail.com>
+
+pkgname=python-pyserial
+pkgver=2.4
+pkgrel=1
+pkgdesc="Multiplatform Serial Port Module for Python"
+arch=('i686' 'x86_64')
+url="http://pyserial.sf.net"
+license=('custom:PYTHON')
+depends=('python')
+source=(http://downloads.sourceforge.net/sourceforge/pyserial/pyserial-$pkgver.tar.gz)
+
+build() {
+ cd $startdir/src/pyserial-$pkgver
+ python setup.py install --root=$startdir/pkg
+ install -D -m644 LICENSE.txt $startdir/pkg/usr/share/licenses/$pkgname/LICENSE.txt
+}
+md5sums=('eec19df59fd75ba5a136992897f8e468')
diff --git a/abs/extra-testing/recstat/PKGBUILD b/abs/extra-testing/recstat/PKGBUILD
new file mode 100644
index 0000000..023a0ed
--- /dev/null
+++ b/abs/extra-testing/recstat/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=recstat
+pkgver=1
+pkgrel=20
+pkgdesc="pkg to help use the System LEDs for Recording Status"
+arch=('i686' 'x86_64')
+url=""
+depends=('python' 'python-pyserial')
+license=('GPL')
+source=(recstat recstat.py run)
+md5sums=('626acb8cdd9e5cdb3a502bc12b828067')
+install=recstat.install
+build () {
+# install -D $startdir/src/recstat $startdir/pkg/etc/rc.d/recstat
+ install -D $startdir/src/recstat.py $startdir/pkg/usr/bin/recstat.py
+ install -D $startdir/src/run $startdir/pkg/etc/sv/recstat/run
+}
+md5sums=('7f4ba41b65ed4d693d60d5ea00e8411b'
+ '7bc206d78a096e6ee80b9bb346619ed4'
+ '3a7cd3382212650e9233b910ed28d046')
diff --git a/abs/extra-testing/recstat/recstat b/abs/extra-testing/recstat/recstat
new file mode 100644
index 0000000..2d72c61
--- /dev/null
+++ b/abs/extra-testing/recstat/recstat
@@ -0,0 +1,56 @@
+#! /bin/sh
+
+set -e
+
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+DESC="serial port encoder status script"
+NAME=recstat
+DAEMON=/usr/bin/$NAME.py
+PIDFILE=/var/run/$NAME.pid
+SCRIPTNAME=/etc/init.d/$NAME
+
+# Gracefully exit if the package has been removed.
+test -x $DAEMON || exit 0
+
+#
+# Function that starts the daemon/service.
+#
+d_start() {
+ start-stop-daemon --start --quiet --make-pidfile --pidfile $PIDFILE \
+ --exec $DAEMON &
+}
+
+#
+# Function that stops the daemon/service.
+#
+d_stop() {
+ kill -9 `cat $PIDFILE`
+}
+
+case "$1" in
+ start)
+ echo -n "Starting $DESC: $NAME"
+ d_start
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: $NAME"
+ d_stop
+ echo "."
+ ;;
+ restart|force-reload)
+ echo -n "Stopping $DESC: $NAME"
+ d_stop
+ sleep 1
+ echo "."
+ echo -n "Starting $DESC: $NAME"
+ d_start
+ echo "."
+ ;;
+ *)
+ echo "Usage: $SCRIPTNAME {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0 \ No newline at end of file
diff --git a/abs/extra-testing/recstat/recstat.install b/abs/extra-testing/recstat/recstat.install
new file mode 100644
index 0000000..ecd58f0
--- /dev/null
+++ b/abs/extra-testing/recstat/recstat.install
@@ -0,0 +1,13 @@
+# arg 1: the new package version
+post_install() {
+ echo ""
+ echo ""
+ echo ""
+ echo " Edit /usr/bin/recstat.py to fit your tuner setup"
+ echo " http://linhes.org/bugs/projects/lin-hes/wiki/_Using_System_LEDs_for_Recording_Status_"
+ echo " To start this program at boot run add_service.sh recstat "
+}
+
+op=$1
+shift
+$op $*
diff --git a/abs/extra-testing/recstat/recstat.py b/abs/extra-testing/recstat/recstat.py
new file mode 100644
index 0000000..8def041
--- /dev/null
+++ b/abs/extra-testing/recstat/recstat.py
@@ -0,0 +1,38 @@
+#!/usr/bin/python
+
+import httplib
+import serial,time
+
+mythStatus = "127.0.0.1:6544"
+encoder1 = "Encoder 1 "
+encoder2 = "Encoder 2 "
+recording = "is local on mythtv and is recording"
+watching = "is local on mythtv and is watching"
+
+#Open COM2
+s = serial.Serial(1)
+#Turn off all lights
+s.setDTR(0)
+s.setRTS(0)
+
+while(True):
+ conn = httplib.HTTPConnection(mythStatus)
+ conn.request("GET", "/")
+ r1 = conn.getresponse()
+ results = r1.read()
+
+ if(results.find(encoder1+recording)!=-1):
+ s.setDTR(1)
+ elif (results.find(encoder1+watching) !=-1):
+ s.setDTR(1)
+ else:
+ s.setDTR(0)
+
+ if(results.find(encoder2+recording)!=-1):
+ s.setRTS(1)
+ elif (results.find(encoder2+watching) !=-1):
+ s.setRTS(1)
+ else:
+ s.setRTS(0)
+
+ time.sleep(1)
diff --git a/abs/extra-testing/recstat/run b/abs/extra-testing/recstat/run
new file mode 100755
index 0000000..150fdb4
--- /dev/null
+++ b/abs/extra-testing/recstat/run
@@ -0,0 +1,7 @@
+#!/bin/sh
+exec 2>&1
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting recstat"
+exec /usr/bin/recstat.py
diff --git a/abs/extra-testing/rrd_stats/PKGBUILD b/abs/extra-testing/rrd_stats/PKGBUILD
index 40f0536..1f987e4 100644
--- a/abs/extra-testing/rrd_stats/PKGBUILD
+++ b/abs/extra-testing/rrd_stats/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=rrd_stats
pkgver=1
-pkgrel=16
+pkgrel=18
pkgdesc="graph system stats"
arch=('i686' 'x86_64')
url=""
@@ -18,3 +18,4 @@ build() {
chown -R http:users $startdir/pkg/data/srv/httpd
chmod -R 755 $startdir/pkg/data/srv/httpd
}
+md5sums=('e3d5f7d56fd1a3f26af0226ddcc53bfa')
diff --git a/abs/extra-testing/rrd_stats/rrd_stats.tgz b/abs/extra-testing/rrd_stats/rrd_stats.tgz
index c141ffa..4f1f3f5 100644
--- a/abs/extra-testing/rrd_stats/rrd_stats.tgz
+++ b/abs/extra-testing/rrd_stats/rrd_stats.tgz
Binary files differ