summaryrefslogtreecommitdiffstats
path: root/abs/extra/autofs/run
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/extra/autofs/run
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra/autofs/run')
-rwxr-xr-xabs/extra/autofs/run16
1 files changed, 15 insertions, 1 deletions
diff --git a/abs/extra/autofs/run b/abs/extra/autofs/run
index b35a4ea..342ade6 100755
--- a/abs/extra/autofs/run
+++ b/abs/extra/autofs/run
@@ -1,5 +1,19 @@
#!/bin/sh
exec 2>&1
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+stat_runit "Starting autofs4 kernel module" && echo ""
set -e # barf if modprobe fails
/sbin/modprobe autofs4
-exec /etc/rc.d/autofs start
+
+stat_runit "Starting autofs automount" && echo ""
+# source application-specific settings
+[ -f /etc/conf.d/autofs ] && . /etc/conf.d/autofs
+
+if [ ! -z "$TIMEOUT" ]; then
+ daemonoptions="--timeout=$TIMEOUT $daemonoptions"
+fi
+
+exec /usr/sbin/automount -f $daemonoptions