summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/cwiid-git/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
commit1f175a7b07b9553ce98d0546ac04dbb925ec0bc9 (patch)
treec969070115611a8a75f23d468aa5e0cf86a08121 /abs/extra/community/cwiid-git/PKGBUILD
parentc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (diff)
downloadlinhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.zip
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.gz
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.bz2
RESYNC EXTRA:
synced extra-testing -> extra repo Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/extra/community/cwiid-git/PKGBUILD')
-rw-r--r--abs/extra/community/cwiid-git/PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/abs/extra/community/cwiid-git/PKGBUILD b/abs/extra/community/cwiid-git/PKGBUILD
new file mode 100644
index 0000000..909f224
--- /dev/null
+++ b/abs/extra/community/cwiid-git/PKGBUILD
@@ -0,0 +1,62 @@
+#Contributor:Andrea Tarocchi <valdar@email.it>
+pkgname=cwiid-git
+#pkgver=`date +%Y%m%d`
+pkgver=20100716
+pkgrel=1
+pkgdesc="Cwiid-git is the bleeding edge version of a wiimote's driver and utility tools"
+arch=(i686 x86_64)
+url="http://github.com/abstrakraft/cwiid"
+license=('GPL')
+
+depends=('bluez>=4' 'gtk2' 'python')
+makedepends=('git' 'make' 'automake' 'autoconf')
+replaces=('cwiid' 'cwiid-svn')
+provides=('cwiid' 'cwiid-git')
+install=('cwiid.install')
+source=()
+
+_gitroot=git://github.com/abstrakraft/cwiid.git
+_gitname=cwiid
+_builddir=$srcdir/$_gitname-build
+
+build() {
+
+ export LDFLAGS=
+
+ cd $srcdir/
+ msg "Connecting to github.com GIT server...."
+ if [ -d $srcdir/$_gitname ] ; then
+ pushd $_gitname && git pull origin && popd
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+ rm -rf $_gitname-build
+ git clone $_gitname $_gitname-build
+
+ cd $_builddir
+
+ aclocal
+ autoreconf
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-ldconfig
+
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+
+# aclocal
+# autoreconf
+
+# ./configure --disable-ldconfig --prefix=/usr --sysconfdir=/etc --with-cwiid-plugins-dir=/lib/cwiid/plugins
+# make LDFLAGS=-L../libcwiid || return 1
+
+# install -d $startdir/pkg/usr/bin
+# install -d $startdir/pkg/etc
+# install -d $startdir/pkg/usr/lib
+# install -d $startdir/pkg/usr/include
+
+# make install LDFLAGS=-L../libcwiid prefix=$startdir/pkg/usr sysconfdir=$startdir/pkg/etc install
+
+# install -D -m644 ./wminput/README $pkgdir/usr/share/doc/cwiid/wminput
+}