summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/js/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-08-03 23:14:05 (GMT)
committerCecil <knoppmyth@gmail.com>2011-08-03 23:14:05 (GMT)
commit998faf16b1b62493b39aa13b3cb53dfac266ef4c (patch)
treee39f222ebd2e5ca78211045d1d12ccc02f8c5516 /abs/extra/community/js/PKGBUILD
parent085e16d501ac72951e7455385cc8af7e90fa02cb (diff)
parenta9c47f145393b31d7f656b14a2952ab6fc6fec58 (diff)
downloadlinhes_pkgbuild-998faf16b1b62493b39aa13b3cb53dfac266ef4c.zip
linhes_pkgbuild-998faf16b1b62493b39aa13b3cb53dfac266ef4c.tar.gz
linhes_pkgbuild-998faf16b1b62493b39aa13b3cb53dfac266ef4c.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/community/js/PKGBUILD')
-rw-r--r--abs/extra/community/js/PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/abs/extra/community/js/PKGBUILD b/abs/extra/community/js/PKGBUILD
new file mode 100644
index 0000000..35db2db
--- /dev/null
+++ b/abs/extra/community/js/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+pkgname=js
+pkgver=1.8.5
+pkgrel=3
+pkgdesc="JavaScript interpreter and libraries"
+arch=(i686 x86_64)
+url="https://developer.mozilla.org/En/SpiderMonkey/1.8.5"
+license=('GPL2')
+depends=('nspr' 'gcc-libs')
+makedepends=('python2' 'zip')
+replaces=('spidermonkey')
+conflicts=('spidermonkey')
+source=(http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
+ js185-destdir.patch)
+md5sums=('a4574365938222adca0a6bd33329cb32'
+ '364834a8391888642c53d78c3a949d94')
+build() {
+ cd "$srcdir/$pkgname-$pkgver/js/src"
+
+ patch -Np0 -i $srcdir/js185-destdir.patch
+
+ ./configure --prefix=/usr --with-system-nspr \
+ --enable-threadsafe
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/js/src"
+ make DESTDIR="$pkgdir" install
+
+ install -m 0755 shell/js ${pkgdir}/usr/bin
+
+ #cleanup
+ rm -f "${pkgdir}/usr/lib/libmozjs185-1.0.a"
+}
+
+# vim:set ts=2 sw=2 et: