summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/libdnet/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-09 01:43:59 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-09 01:43:59 (GMT)
commit6b218299785aedd78128a9c7831aff1a6eefdcb8 (patch)
tree79f48e3bac89f7120496e6b3021072212fa6a780 /abs/extra/community/libdnet/PKGBUILD
parentf33c5716af099ce4d779cf67f65204f11b551ed6 (diff)
parente40ac065f9a09f99b37e898b8684d70a0984f399 (diff)
downloadlinhes_pkgbuild-6b218299785aedd78128a9c7831aff1a6eefdcb8.zip
linhes_pkgbuild-6b218299785aedd78128a9c7831aff1a6eefdcb8.tar.gz
linhes_pkgbuild-6b218299785aedd78128a9c7831aff1a6eefdcb8.tar.bz2
Merge branch 'testing' of knoppmyth.net:linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/community/libdnet/PKGBUILD')
-rw-r--r--abs/extra/community/libdnet/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra/community/libdnet/PKGBUILD b/abs/extra/community/libdnet/PKGBUILD
new file mode 100644
index 0000000..70cf6e4
--- /dev/null
+++ b/abs/extra/community/libdnet/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 27071 2010-09-17 12:26:08Z schuay $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: James Fryman <jfryman@gmail.com>
+
+pkgname=libdnet
+pkgver=1.12
+pkgrel=5
+pkgdesc="A simplified, portable interface to several low-level networking routines"
+arch=(i686 x86_64)
+makedepends=(python2)
+optdepends=(python2)
+install=(libdnet.install)
+license=("BSD")
+url="http://code.google.com/p/libdnet/"
+options=('!libtool')
+source=(http://libdnet.googlecode.com/files/libdnet-$pkgver.tgz)
+md5sums=('9253ef6de1b5e28e9c9a62b882e44cc9')
+
+build() {
+ mkdir -p $pkgdir/usr/bin
+
+ [ $CARCH == "x86_64" ] && export CFLAGS=-fPIC
+
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make && make DESTDIR=$pkgdir install
+
+ cd python && \
+ python2 setup.py install --root=$pkgdir
+
+ install -D -m0644 ../LICENSE $pkgdir/usr/share/licenses/libdnet/license
+ mv $pkgdir/usr/man $startdir/pkg/usr/share/
+}